Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

idle prob.

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by OKIEnVA, Aug 28, 2006.

  1. OKIEnVA

    OKIEnVA Registered Member

    Joined:
    Jan 16, 2006
    Posts:
    32
    Likes Received:
    0
    Location:
    Northern virginia
    hey guys i got a 91 k5 350 tbi. this prob been goin on for yrs but getting worse here lately. after running it kinda hard or playing wit the throttle it will start to idle real low like shes strugglin to stay running, if i pop it in nerutral rev it up for a lil bit, then wham it magically clears up and goes back to running good. any ideas or things i could check.?
     
  2. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    A bad throttle body base gasket will cause idle problems. Pretty common for them to go out. Also check all your Vaccum lines for cracks/breaks
     
  3. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    Yeah, ditto what Thunder says. Are you getting any codes? When was your O2 sensor last changed? Done any mods to the motor? Cleaned your throttle body lately? Running an injector cleaner through may well help with that.
     
  4. OKIEnVA

    OKIEnVA Registered Member

    Joined:
    Jan 16, 2006
    Posts:
    32
    Likes Received:
    0
    Location:
    Northern virginia
    motors stock, ive ran some tranny fluid threw the throttle bosy put some cleaner in the fuel tank, i was gettin a chk eng light, but i was tired of looking at it over the yrs so i took the bulb out of the cluster. ill bring it in the shop tomarrow and see what i can find. o2 sensor never been replaced. i got 152 thousand on her. when shes not idling like crap shes strong. and pretty smooth, the part that confuses me is it will last for a couple seconds, then clear right up. like nothing was ever wrong.
     
  5. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    Put your bulb in and check the codes!
     
  6. loafer

    loafer 1/2 ton status

    Joined:
    Aug 19, 2003
    Posts:
    634
    Likes Received:
    0
    Location:
    Lyman, Maine
    Usually a bad TB gasket will cause a high idle because it creates a vacuum leak. Still worth checking though.

    When you decelerate and come to a stop does it stumple and/or idle too low? If so it may be a leaky/bad EGR valve.
     

Share This Page