Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

ignition problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Jishory, Sep 25, 2005.

  1. Jishory

    Jishory 1/2 ton status

    Joined:
    Jan 8, 2002
    Posts:
    1,367
    Likes Received:
    0
    Location:
    Palmdale, CA
    i just got done tearing my truck apart for a manual swap and now that it is back together (besides the t-case) i turn the key to test my new stereo and turning the key was really hard, there was alot of resistance... and when i crank it over nothing is getting power. anybody have a similar problem before?
     
  2. toocalm

    toocalm Registered Member

    Joined:
    Feb 1, 2004
    Posts:
    13
    Likes Received:
    0
    Location:
    Long Island, NY
    Sounds like the cylinder is not positioned correctly, or the cylinder itself might be a problem. Just a guess. . .
     
  3. Jishory

    Jishory 1/2 ton status

    Joined:
    Jan 8, 2002
    Posts:
    1,367
    Likes Received:
    0
    Location:
    Palmdale, CA
    :confused: i dont know electrical/ignition or any of that stuff. how would i check?
     
  4. camiswelding

    camiswelding 1/2 ton status

    Joined:
    May 25, 2003
    Posts:
    2,545
    Likes Received:
    0
    Location:
    Redding, CA
    Josh...

    Time to invest in a manual...


    It does sound like your lock cylinder took a dump.. and its not engaging the electrics... were you having key problems before?....


    and dont forget with your swap to bypass the nuetral safety swithc so you can start that thing in gear... for getting over stuff dead heading... I dont even think I gave you the switch but Im not sure

    cam
     

Share This Page