Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Ignition System(Help)

Discussion in 'The Garage' started by Blazer1AB, Oct 29, 2005.

  1. Blazer1AB

    Blazer1AB Registered Member

    Joined:
    Sep 1, 2005
    Posts:
    29
    Likes Received:
    0
    Location:
    KC
    Okay, I've been plauged with this problem since I bought my blazer almost two months ago. It works fine sometimes and other times it will crank, but will not start- it has no spark. First I changed the cap, rotor, coil and ignition module and I thought that did the trick, but obviously not. I thought the only thing that could be left was the pick-up assembly. So I decided, I want this to be dependable, lets do this the right way, so I put a whole new distributor in. So now I have a new distributor(came with ignition module) and I put my new cap and rotor and coil on it. Starts up fine, then I time it, and it is not running perfect, because of what I think is a very gross carb that needs to be rebuilt. Then it dies suddenly and wont start, so I decide to put in my other ignition module, it fires right up, first time. It runs a little bit, then dies. I am on my third ignition module and I cannot figure out why its burning them up. Everything was new, as well as greased all electrical things. What the hell is my problem here?? This is really starting to piss me off and I am just contemplating selling it. Please help if you can.
     
  2. Z3PR

    Z3PR Banned

    Joined:
    Mar 30, 2002
    Posts:
    19,217
    Likes Received:
    0
    Location:
    Everywhere
    Sounds like something funny going on there. Check the ignition relay, then the wires down at the starter, trace the wire from the starter on up.
     

Share This Page