Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Im about to blow up my truck.. Hydro ass is no longer working right hlp pls

Discussion in 'The Garage' started by Silver84k5, May 27, 2003.

  1. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    ok when i finished the hydro/xover install, everything was working... It wasnt what i thought it should work like, I though i would have more steering power then i do, but nonetheless i was able to turn my wheels lock to lock at a dead stop without the belt squeaking or having to apply a lot of force.. Well im getting ready to drop the tranny (a whole nother post) And i notice i cant steer for [naughty word] /forums/images/graemlins/angryfire.gif. I try to bleed the system again, to no avail /forums/images/graemlins/angryfire.gif. I try turning the wheels lock to lock, and the belt starts Squealin like a stuck pig, and the steering wheel wont F'ING turn /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif... what is wrong now? pump? box?.... Thx for any input....
     
  2. willyswanter

    willyswanter 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2000
    Posts:
    2,690
    Likes Received:
    0
    Location:
    Bakersfield, CA
    Welcome to my hell! I haven't been able to get mine to work right since I put it on. Can't turn at all at a stop, can't turn at idle, have to give it gas... Tried new pump, nothing... I'm about to rip it off...
     
  3. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    heh i got it fixed, right after i posted this i went out and checked the belt, kinda loose, so i tightened it up and it worked.... btw i was so pissed becuase i was getting ready to rip the tranny out and i couldnt find my coveralls, and when i finally did i Rip the crap out of them trying to put them on... heh /forums/images/graemlins/1zhelp.gif
     

Share This Page