Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

I'm pissed at the truck!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by thatK30guy, May 24, 2002.

  1. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    I\'m pissed at the truck!!

    I just got the '85 K30 back today after getting new plugs, wires, and a freshly rebuilt carb put on. The timing had been set and carb tuned to where it ran pretty good.

    All that ran good for the first part of the evening. Later, around a couple hours later, the damn thing starts popping again. Just a little bit of popping now and then. Also has a lack of power when accelerating at a certain speed.

    Before the rebuilt carb went on, I had the Edelbrock carb tuned and the truck ran fine, too. Just when I drove it a little more and longer, it popped again. So I had a different carb rebuilt and the popping came back tonight.

    What the hell is going on here? With two fairly new or rebuilt carbs, something is not right here. The timing is set. Plugs and wires are all new.

    I'm beginning to wonder if the camshaft maybe has some flat lobes?

    Keep in mind, right after the work had been done to the truck, it ran fine and smooth. Just after awhile the popping came back, on both carbs. /forums/images/icons/mad.gif

    HELP ME OUT HERE!!! This is my daily driver now. /forums/images/icons/frown.gif Any ideas?
     
  2. rlhenry

    rlhenry Registered Member

    Joined:
    Mar 6, 2002
    Posts:
    93
    Likes Received:
    0
    Location:
    Morenci, AZ
    Re: I\'m pissed at the truck!!

    Can you describe the 'popping' a little more?
     
  3. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Re: I\'m pissed at the truck!!

    Like a backfire, but out the exhaust. That's why I'm thinking it may be valve train related. /forums/images/icons/frown.gif
     
  4. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    Re: I\'m pissed at the truck!!

    Sounds like you've pretty much eliminated the carb, and I'm guessing you've covered vacuum leaks at least once around the engine bay. I'm no engine guru but, it kinda sounds like it's getting out of time. Your description of “popping” sounds to me like a cylinder(s) firing when a valve is still open. And getting worse over time may indicate something not tight or slipping or maybe even something that is sticky. Is the advance sticking? Or maybe the distributor shaft is striped or broken letting it get out of time a bit when it’s running? I would throw a timing light on there just for grins and see what you've got. You've got all the goodies laying around, maybe try the big hammer approach by just replacing the distributor. Also, do you have one of those slotted adjustable degree gears on the cam? Or I guess it could be a weak exhaust lifter not letting a cylinder purge?

    Just throwing some thoughts out. I suck at engine diagnostics even when I’m looking at it, much less from a description. /forums/images/icons/laugh.gif So hopefully one of the engine guys will be able to help out soon…
     
  5. gokartergo

    gokartergo 3/4 ton status Staff Member Moderator

    Joined:
    Dec 2, 2000
    Posts:
    5,855
    Likes Received:
    0
    Location:
    Hollister, CA
    Re: I\'m pissed at the truck!!

    Sounds like a cross fire in the dist... Make sure there is no moisture in there.. And inspect the cap for cracks..Probably should just replace it..my 02.Dan
     
  6. fender

    fender Registered Member

    Joined:
    Aug 18, 2001
    Posts:
    92
    Likes Received:
    0
    Location:
    port moody b.c.
    Re: I\'m pissed at the truck!!

    i'm sure you've already checked it, but if you haven't,make sure all the wires are going to the right cylinders...if two of them are switched it can cause backfireing
     
  7. 70~K5

    70~K5 1/2 ton status

    Joined:
    Apr 13, 2002
    Posts:
    2,032
    Likes Received:
    0
    Location:
    sillycon valley
    Re: I\'m pissed at the truck!!

    Also don't run your plug wires parallel to each other as the spark can jump from one to another.
     
  8. 70~K5

    70~K5 1/2 ton status

    Joined:
    Apr 13, 2002
    Posts:
    2,032
    Likes Received:
    0
    Location:
    sillycon valley
    Re: I\'m pissed at the truck!!

    Also don't run your plug wires parallel to each other as the spark can jump from one to another.
     
  9. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    Re: I\'m pissed at the truck!!

    It sounds like you've replaced a lot of stuff, but you never mentioned whether you replaced your cap and rotor.

    ANy time I've had a "popping" issue, I've traced it back to the secondary ignition somewhere. One time I solved it with fresh wires, and within a week the sucker was running poorly again. It ended up being a bad dist. cap that fried a couple of my new wires.

    Since then, whenever I do a tuneup, I replace all the ignition stuff at the same time.
     
  10. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    Re: I\'m pissed at the truck!!

    How old is the timing chain in that motor?
     
  11. wrathORC

    wrathORC 1/2 ton status

    Joined:
    Apr 27, 2002
    Posts:
    908
    Likes Received:
    0
    Location:
    Hancock, MI
    Re: I\'m pissed at the truck!!

    Go out at night and spark up the truck and pop the hood. Take a peek without any lights on and see if you've got an early fourth-of-July celebration going on under there. If so, it's time for a new cap and rotor. I'd buy one anyway since you put plugs and wires in. It'll cost you less than $15 for cheap ones.

    I'd also be doing some spark plug reading.

    Is it difficult to start after you shut it off after you have had this problem? If so, it's a telltale sign of a tired ignition coil. If it hasn't been replaced yet it's _definitely_ time for a new one. Besides, might as well do it while you have the distributor cap off.
     
  12. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    Re: I\'m pissed at the truck!!

    Good point on the cap and rotor. When I read the first post, I they had been changed. Now I see that it was just plugs and wires. Also, between Wes and his mechanic friend, i figured all the other obvious stuff had been covered. That's why I was sort of looking beyond the obvious...
     
  13. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    Re: I\'m pissed at the truck!!

    Hmm, add weak/worn lifter or broken push rod or rocker on the exhaust side to my list. That would cause spent gases to "pop" back through the carb when the intake opens.

    Also, one of your earlier posts indicate you thought the popping was in the exhaust. Are you sure? Unburned gasses still burning when the ehaust valve opens pretty much invalidates many of my ideas. Burned valve maybe? Done a compression test? Just more brain storming. Good luck, I know how agravating this crap can be. I was ready to take a 12 lb sledge to my TBI 350 at one point back when I was messing with all the EGR problems (checked EGR? /forums/images/icons/wink.gif )...
     
  14. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    Re: I\'m pissed at the truck!!

    Sometimes it's the obvious stuff that is overlooked...../forums/images/icons/wink.gif

    God knows I've spent a lot of time trying to figure out a problem and it turned out to be something simple.
     
  15. BadDog

    BadDog SOL Staff Member Super Moderator Author

    Joined:
    Feb 24, 2001
    Posts:
    7,777
    Likes Received:
    11
    Location:
    Phoenix, AZ
    Re: I\'m pissed at the truck!!

    Hehe, aint that the truth! It's a lesson I learn over and over again. /forums/images/icons/laugh.gif
     
  16. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Re: I\'m pissed at the truck!!

    Paul, the cap and rotor were changed about 2 years ago, but I just thought why not put another set on. Will be getting to that soon anyways. /forums/images/icons/wink.gif
     
  17. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Re: I\'m pissed at the truck!!

    Frank, I still have all the receitps from the previous owner whom rebuilt the motor.

    He installed a new double roller timing chain set. I think there is about 30 - 40K on the rebuild job.
     
  18. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Re: I\'m pissed at the truck!!

    I took the truck out to my fathers today and thats exactly what he suggested me to do tonight...turn it on in the dark and watch for any sparking which like you explained would show up like a fourth of July show. /forums/images/icons/wink.gif

    Gonna do this tonight and see what happens.
     
  19. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    Re: I\'m pissed at the truck!!

    I hope that solves your problems, Wes.

    I went through the same thing as you about 4 years ago. We checked everything we could, including the cat in case it was plugged. I ended up doing the wires and plugs and it went away. I don't need to tell you how frustrated I was when my problems returned a week later/forums/images/icons/mad.gif!!!!

    I checked the cap and, lo and behold, it was cracked and fried inside eevn though it looked ok from the outside. It had actually been shorting out and sending spark to two cylinders at the same time, which explained the goofy running conditions. I also needed to replace a couple of wires because they got fried too.....
     
  20. thatK30guy

    thatK30guy 1 ton status Premium Member

    Joined:
    Jan 12, 2001
    Posts:
    32,076
    Likes Received:
    55
    Location:
    .
    Re: I\'m pissed at the truck!!

    Russ, it's definitely coming out of the exhaust.

    My buddy did a compression check two weeks ago and every cylinder tested between 120 and 125. /forums/images/icons/cool.gif

    BTW, today I took two quarts of Dexron and poured it into the carb while revving up the motor. Think I got some carbon build-up in the motor and it may have helped to free up the build up.
    I smoked the whole neighborhood with white smoke. /forums/images/icons/laugh.gif
    Then took the truck for a drive and drove it hard. At one corner on the highway when I turned around to come back to town, I mashed the gas and sat there. At first the truck was boggish off the line and once the 4 barrels opened up, the truck came to life and started spitting black smoke out, just short bursts of it, and quit smoking after that.
    I got back to town and the popping went away for good, BUT, every now and then it does a small pop.
    So the popping is not 100% gone yet, but almost.
    I'm gonna do the new cap and rotor and see what happens after that. /forums/images/icons/wink.gif
     

Share This Page