Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

is my speedo headed south?

Discussion in 'The Garage' started by big83chevy4x4, Dec 12, 2003.

  1. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    when it is cold out, it makes this funny whining sound and the speed triples and sometimes quadruples /forums/images/graemlins/eek.gif like today it said i was doing 85 and i was barly doing 35. the colder it is the worse it is, especially the whining, it sounds liek it is going to explode /forums/images/graemlins/crazy.gif
     
  2. 99firehawk

    99firehawk 1/2 ton status

    Joined:
    Dec 15, 2002
    Posts:
    491
    Likes Received:
    0
    Try un hooking it at both ends and giving it a squirt of wd40 or something similar.
     
  3. scrappyk5

    scrappyk5 1/2 ton status

    Joined:
    Mar 17, 2002
    Posts:
    2,099
    Likes Received:
    0
    Location:
    virginia
    you need to either get the cable itself lubed up or
    replaced. mine did the same thing as yours , but i kept
    putting off till it was too late and it stripped out the
    drive gear inside the t-case. /forums/images/graemlins/eek.gif
     
  4. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    im preaty sure its not the cable (i do have a new one) the dash sounds like it is going to explode and when the truck warms up inside is works fine. but i will put the new cable in
     
  5. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    Pull the cable. Hold an end in each hand. Rotate the actual cable. If the "sheath" bounces around, or tries to twist up, replace it. If not, lube it, and forget it. No point in replacing a part that isn't the problem.

    The noise more than likely is from the speedometer itself. Mine (normally in the morning) would start screaming about 1/2 mile after starting to drive, and would typically peg out over 85 when I would travel at approximately 45MPH. It would slowly "wind down", and eventually settle back to "correct", typically when I stopped at a light or something.

    If the cable itself was the problem, you would expect the speedometer to jump (as the cable twists up on itself, and unloads) as opposed to reading a steady, higher MPH, which is what I understand yours to be doing.

    Very annoying, but oddly enough, it just went away in my case, and hasn't come back since. But I'm still going with an electric speedo. /forums/images/graemlins/smile.gif

    Don't know as there is any way to fix the problem yourself, the speedo mechanism is pretty precise. (magnets, small springs, etc) I'm sure a speedo shop could do it, but as common as these are, I'd get one from a vehicle being parted out first.
     
  6. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    the housing got too close to the exhaust and it melted the housing for about 4" [ QUOTE ]
    Mine (normally in the morning) would start screaming about 1/2 mile after starting to drive, and would typically peg out over 85 when I would travel at approximately 45MPH. It would slowly "wind down", and eventually settle back to "correct", typically when I stopped at a light or something.


    [/ QUOTE ] mine does exactly this but only when it is cold

    i have the complete guage cluster from my k10 and will probably swap them in /forums/images/graemlins/thumb.gif
     
  7. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    [ QUOTE ]
    when it is cold out, it makes this funny whining sound and the speed triples and sometimes quadruples /forums/images/graemlins/eek.gif like today it said i was doing 85 and i was barly doing 35. the colder it is the worse it is, especially the whining, it sounds liek it is going to explode /forums/images/graemlins/crazy.gif

    [/ QUOTE ]

    bad cable

    simply unscrew it from tranny for now til you find another cable, it is binding up inside the housing cuz it is worn no one ever lubed it yp, mine is getting like this too, im just going to disconnect it and eventually run a new cable, it does this worse in winter and such when its cold as ^#@! out
     
  8. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    [ QUOTE ]
    bad cable


    [/ QUOTE ]

    So how does a bad cable make the speedometer consistently read faster than actual speed?
     

Share This Page