Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Is this spring required in my hubs???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by deek, Jul 22, 2003.

  1. deek

    deek 1/2 ton status

    Joined:
    May 6, 2003
    Posts:
    142
    Likes Received:
    0
    Location:
    Great Bend, KS
    I have taken apart the hubs on both sides, one side had a spring in it, it's about 2" wide & 5" long (as seen on page 8-14 of a haynes). The thing is one side didn't even have this & as far as i know that side worked just fine. Do i need this with locking hubs or is this something from when it was fulltime 4wheel drive?
     
  2. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,063
    Likes Received:
    71
    Location:
    Pleasanton, CA.
    You do not need the spring, it was needed when it was a fulltime 4WD without locking hubs.
     
  3. bigjbear

    bigjbear 1 ton status Staff Member Moderator

    Joined:
    Feb 18, 2000
    Posts:
    13,973
    Likes Received:
    454
    Location:
    Marietta GA
    It depends on what brand of hubs you are using. Warn doesn't need it, Spicers do. That spring pushes the cog out that engages the bearing hub on the Spicer set up.
     
  4. deek

    deek 1/2 ton status

    Joined:
    May 6, 2003
    Posts:
    142
    Likes Received:
    0
    Location:
    Great Bend, KS
    well then i guess i lucked out, I'm using the warn hubs /forums/images/graemlins/thumb.gif
     

Share This Page