Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Is this the VSS...How to adapt it? **(PICS)**

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BlueOx, Jul 22, 2002.

  1. BlueOx

    BlueOx 1/2 ton status

    Joined:
    Aug 6, 2000
    Posts:
    239
    Likes Received:
    0
    Location:
    Houston, Tx
    As many of you all know I'm in the process of installing the TBI to my 85 Blazer. I took off the gauge cluster to see what was wrong with the lights and this is that I found. I took a few pictures of the VSS or at least what I think is the VSS. There are three wires that leave the back of the speedo and go into a some sort of green plug. The green plug then plugs into another white plug that has three wires. One wire goes to the fuse box, one to a black box under the dash, and one to the cruse control unit under the hood. I was going to puchase the VSS from JTR but if I can make this work in can save the money for something better.
    Does anyone know how to incorporate the old VSS I have now (if that is what it is)to the new system.

    Thanks,
    ChARLES

    pictures
     
  2. BlueOx

    BlueOx 1/2 ton status

    Joined:
    Aug 6, 2000
    Posts:
    239
    Likes Received:
    0
    Location:
    Houston, Tx
  3. 88streetblaze

    88streetblaze 1/2 ton status

    Joined:
    Jun 27, 2001
    Posts:
    314
    Likes Received:
    0
    Location:
    middle of sticks, oklahoma
    yes that is the vss, i don't have the schematics on me but as soon as i get home i'll let you know which wire is which(that is if the wire colors are the same for an 88, should be but we'll find out,
     
  4. BlueOx

    BlueOx 1/2 ton status

    Joined:
    Aug 6, 2000
    Posts:
    239
    Likes Received:
    0
    Location:
    Houston, Tx
    88streetblaze, thanks alot


    Charles
     
  5. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    I think the other box in your hand is probably for cruise control. Not positive, but the electric cruise for the cars and trucks in the 80's was fed by VSS, and was in a seperate box like that.

    Of course the ECM also gets VSS signals.

    http://92b4crs.tripod.com/86wiring/dia-pics/33-0.jpg shows the buffer (the small blue box in your pictures that bolts to the speedo head) and the wires out of it. Looks like the buffer should have the "ECM" side labeled with 8, 9, and 10 for the wires. Odd, usually they are A, B, etc., but who knows.

    Just make sure your system requires 2 pulse VSS, and not 4 or whatever GM went to after 2. I have no idea how to tell the difference in pulse just by looking at the setup, but as I recall, all the way up to '91, the trucks would be 2 pulse. Somewhere after that time it was changed to more pulses, but not sure when....
     
  6. 88streetblaze

    88streetblaze 1/2 ton status

    Joined:
    Jun 27, 2001
    Posts:
    314
    Likes Received:
    0
    Location:
    middle of sticks, oklahoma
    as for the pulse thing yeager is refearing to i believe that gm used a 4 pulse on everything up until '93-or 94 where they went to a 15 pulse, so i don't think there will be any problem there, according to the diagrams you won't actually need any of the wires off of the vss/or cruise module if the wiring is similar to mine,

    the quick way to find the wire that will go to the ecm would be if you have an aldl plug, there will be a six port connector for no apparent reason under the dash around the ash-tray area, there will be 6 wires, orn, blk/wht, wht/blk, brn, brn/wht, the brown with no stripe is the vss input to the A10 cavity on the ecm.(pic of connector at connector
    ignore the wire coming out of the loom on the pic., you won't have that, hopefully that will be the info you need, if not let me know and i'll get you the detailed info about every wire
     
  7. BlueOx

    BlueOx 1/2 ton status

    Joined:
    Aug 6, 2000
    Posts:
    239
    Likes Received:
    0
    Location:
    Houston, Tx
    yeager, I tried to open the link but it did not show anything. you are correct about the black box, it is for the cruse control. I just went out to look at the wires again and it looks like only one of the wires goes to the cruse control box. The other two go to A IGN HOT and to the cruse control under the hood. What do you think.

    88street, I looked for the plug you were talking about but I dont have it. I have an 85 blazer and I guess the wiring is different.

    It looks like this will be a pain and i might buy the one JTR sells /forums/images/icons/mad.gif

    Does any one here have a wiring diagram for this that they could email me.

    Thanks
    Charles
     
  8. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    go to www.thirdgen.org
    On the left side, click on technical articles. Under "electrical" click on "1986 wiring diagrams".
    Scroll down to the link titled "Vehicle Speed Sensor".

    It works, I was just looking at it : )
     
  9. 88streetblaze

    88streetblaze 1/2 ton status

    Joined:
    Jun 27, 2001
    Posts:
    314
    Likes Received:
    0
    Location:
    middle of sticks, oklahoma
    if you can't figure it out this is the style of vss i'm using vss

    it weird looking at the schematics, it is showing 2 vss, but i think if you look on the plug that plugs into the green box, there will be 3 or 4 wires,
    blk - ground
    pnk/blk - goes to fuse box, so more than likely power
    and either 1 or 2 yel, both go to the cruise control module and are labeled speed sensor,
    since you don't have the input for the computer already there i would look at the yel wire. try tapping in there for your computer input. maybe that will work for ya and save $70.
     

Share This Page