Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

It runs now BUT....HELP!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Hossbaby50, Feb 9, 2003.

  1. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    I am having some problems. I had my starter and fuel pump go out on my truck. So I changed them both. The fuel pump the other day and the starter today. I got it to fire up and run, but now I am having problems that it didn't have before.

    The truck will run and idle fine, but if I punch the throttle it stumbles BAD, or dies all together. But if I ease into the throttle VERY slowly it won't stumble and will rev without problem. What the hell is wrong now? It hasn't run for a week, and now it is finally running, but real shitty. Also, if I have the timing set real high (16+ BTDC) it stumbles bad when I open the throttle, but if I have it set normal (8 BTDC) it will stumble and die. WTF?

    Spec. 350, w/qjet, ac delco duel pump (new)

    I have checked for vacuum leaks and I can't find any. Please Help. Thank you

    Harley
     
  2. milspecjimmy

    milspecjimmy 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    901
    Likes Received:
    0
    Location:
    raymond, maine
    fuel filter maybe? plugged enough not to feed the fuel fast, but not enough to keep it from slowly reving?
     
  3. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    I don't have a fuel filter in the carb anymore. I have one right next to the fuel tank. The part of the house were the old fuel pump goes stripped and my mechanic sealed it with no filter, and then moved it by the tank.
     
  4. milspecjimmy

    milspecjimmy 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    901
    Likes Received:
    0
    Location:
    raymond, maine
    even so how old is it?
    it can still cause this
     
  5. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    the fuel filter in there was replace 1 month ago, and it is clear so I can see that it is not clogged.

    The other thing i am worried about now is that at idle you can see the fuel flowing threw it, but it is not completely filling the fuel filter. So I don't know if the new fuel pump is pulling enough fuel at idle.
     
  6. daimok

    daimok Registered Member

    Joined:
    Jul 18, 2002
    Posts:
    40
    Likes Received:
    0
    Location:
    north carolina
    are you getting any pressure build up when you take the gas cap off ? [ plugged vent } i took my charcoal canister off and man did it pressurize quickly. your filter should be full if the vents are ok
     
  7. SickboySS

    SickboySS 1/2 ton status

    Joined:
    Nov 24, 2002
    Posts:
    154
    Likes Received:
    0
    Location:
    Auburn Ma
    could it be the accelerator pump in the carb?
     
  8. milspecjimmy

    milspecjimmy 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    901
    Likes Received:
    0
    Location:
    raymond, maine
    sounds like my dodge, check all the lines for cracks, especially the rubber ones. if it can suck air, it will be like a broken soda straw. it will pull the easiest thing. at idle it gets enough fuel, but when you floor it , its easier to sck air so it does.
     

Share This Page