Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

It sure moves, but it won't stop...

Discussion in '1969-1972 K5 Blazer | Truck | Suburban' started by ak7, Sep 2, 2002.

  1. ak7

    ak7 Registered Member

    Joined:
    Feb 15, 2002
    Posts:
    57
    Likes Received:
    0
    Location:
    Hayward, CA
    It sure moves, but it won\'t stop...

    So I finally got my motor dropped in and everything hooked up. I had a few problems with my fuel pump and HEI distributor but all of that is worked out. Just when I thought I was ready to cruise down the street I figured I should check my brakes. So yeah, they work, but I have to stand up on the break pedal just to get the truck to stop. I swapped out the booster and still have the same problem. Any sugguestions?

    ak7
     
  2. 1HIHUM

    1HIHUM 1/2 ton status

    Joined:
    Jun 28, 2000
    Posts:
    366
    Likes Received:
    0
    Location:
    Fremont, CA
    Re: It sure moves, but it won\'t stop...

    I take it you've already bled the brakes.Have you checked to make sure your getting vacuum? Low on fluid maybe? Sounds stupid, but sometimes it's the basic stuff that can cause a problem.
     
  3. ak7

    ak7 Registered Member

    Joined:
    Feb 15, 2002
    Posts:
    57
    Likes Received:
    0
    Location:
    Hayward, CA
    Re: It sure moves, but it won\'t stop...

    Thanks for the helpful tips. This is actually the first time that I have ever worked on a vehicle. I'm kind of learning as I go. I actually figured out a little while ago. I had all of my vacuum lines hooked up but I had the booster hooked up to the carb. What I did was hook the booster vacuum straight to the manifold and that solved my problem. I'm guessing the carb could not create enough vacuum for the brake booster.

    ak7
     
  4. 79Beast

    79Beast 1/2 ton status

    Joined:
    Dec 9, 2001
    Posts:
    1,155
    Likes Received:
    0
    Location:
    Georgia
    Re: It sure moves, but it won\'t stop...

    Did your brakes work before the engine swap, or was it not moving when you got it? Make sure you have a GOOD source of engine vacuum going to the booster. You need unported manifold vacuum. Did you install a radical cam that is bleeding off your vacuum? Is your booster good? Is the pedal hard or squishy?
     

Share This Page