Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

It wont start!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 77k5bogger, Feb 4, 2003.

  1. 77k5bogger

    77k5bogger Registered Member

    Joined:
    Feb 3, 2003
    Posts:
    40
    Likes Received:
    0
    Location:
    Winneconne Wisconsin
    Alright my k5s acting up. It wont start. Just cranks over and over. I replaced the ignition modual new plugs, fuel filter, recently. Its getting gas and it also has spark. but it just wont fire up. I spray starting fluid in the carb and it sounds like it is gonna start but it doesnt. Im getting frustrated. The engine is a 77 350 with a quadrajet manual choke. If you guys have any ideas pleas help me. thanks, Derek /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/k5.gif
     
  2. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    The only issue left is either timing or wrong order of the plugs.
    I am assuming it was running before the change so timing chain is not an issue?
     
  3. 77k5bogger

    77k5bogger Registered Member

    Joined:
    Feb 3, 2003
    Posts:
    40
    Likes Received:
    0
    Location:
    Winneconne Wisconsin
    Its not the order of the plug wires I checked it like 10 times my friend checked it too. Yeah it was running before. When I checked the spark it looked kind of weak. Would it maybe be my coil?
     
  4. jakeslim

    jakeslim 1/2 ton status

    Joined:
    Sep 18, 2002
    Posts:
    2,686
    Likes Received:
    0
    Location:
    Napa, CA
    change the coil if you can. I would check under the cap to ensure everything nothing is loose. I take it you did not remove the distributor. Make sure the coils red wire is making good contact with the power connector.
     
  5. 4DiggerDan

    4DiggerDan 1/2 ton status

    Joined:
    Feb 2, 2003
    Posts:
    103
    Likes Received:
    0
    Location:
    Montucky, USA
    Did you just have the distributor out for any reason? Could be 180 out..?? Spark doesn't do you much good on the exhaust stroke ya know /forums/images/graemlins/wink.gif
     
  6. 77k5bogger

    77k5bogger Registered Member

    Joined:
    Feb 3, 2003
    Posts:
    40
    Likes Received:
    0
    Location:
    Winneconne Wisconsin
    No I didnt take the distributor out. I m going to replace the coil tomorrow. I ll also make sure nothing is loose.
     

Share This Page