Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

its started (timing was the problem) but now it is knocking

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by solowookie, Sep 16, 2001.

  1. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    well I got the thing started, but now I got a good knock on the left side of the engine... [​IMG]

    I'm gonna borrow a stethescope so I can hear where the problem is (what cyl. top end or bottum end)

    <font color=blue> Jeff - may the force be with you</font color=blue>
    <a target="_blank" href=http://coloradok5.com/gallery/Jeffs-Stuff>link to k5's</a>
     
  2. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    this thing seems to be running really rich... I am wondering if that can be causing the knock??? the timing is obviously off, but I am wondering if there is anything easy I should be checking before I worry about the stethoscope???

    <font color=blue> Jeff - may the force be with you</font color=blue>
    <a target="_blank" href=http://coloradok5.com/gallery/Jeffs-Stuff>link to k5's</a>
     
  3. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    I would check the timing, the advance mechanism and the firing order....
     
  4. mrspureinsanity

    mrspureinsanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    154
    Likes Received:
    0
    Is this a new/ rebuilt motor Jeff? If its a used motor or the 1 that was in it, it may have broken loose some carbon. I had a car that I worked on that was wrecked real hard and was in my stall for over a month w/out being started. When I fired it up it had a knock, Scared the crap outta me! Anyway I was told to leave it run for a while and it would clear up. I ws skeptical but handed it off to the service dept, so it would be on their head if it grenaded. After about 20- 30 min. it quit.

    Its a possibility.

    REMEMBER THE VICTIMS, AND THEIR FAMILIES!!! STAND PROUD, WE ARE AMERICANS!!!!!!!
     
  5. mrspureinsanity

    mrspureinsanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    154
    Likes Received:
    0
    OOPS! Im posting under my wifes name! Gotta fix that! LOL!

    REMEMBER THE VICTIMS, AND THEIR FAMILIES!!! STAND PROUD, WE ARE AMERICANS!!!!!!!
     
  6. solowookie

    solowookie 1/2 ton status

    Joined:
    Mar 31, 2001
    Posts:
    3,880
    Likes Received:
    0
    Location:
    Wyoming
    actually I went back out, and noticed it was running really really rich... I started tinkering with the dist. so I could run it for the 30 min. and it went away.

    I think I was actually hearing the thing back fire. (didn't sound like a backfire until the thing changed a bit) [​IMG]

    <font color=blue> Jeff - may the force be with you</font color=blue>
    <a target="_blank" href=http://coloradok5.com/gallery/Jeffs-Stuff>link to k5's</a>
     

Share This Page