Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Ive got to revive my 700R4

Discussion in 'The Garage' started by BigBurban350, Sep 21, 2003.

  1. BigBurban350

    BigBurban350 1/2 ton status

    Joined:
    Jun 9, 2002
    Posts:
    711
    Likes Received:
    0
    Location:
    Michigan
    I think the 2-3 shift servo seals are bad because I lost 3rd gear. Everytime it shifted into 3rd it would slip bad. I rebuilt it once with new clutches and put a shift kit thinking it would help the 2-3 shift, nope same problem and I once again lost 3rd gear.

    I have access to jet washers to clean up everything in the housing and valve body. My only concern is where do I find new servo seals for the 2-3 shift servo? Would it be any better to find a new shift servo?
     
  2. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    TV cable adjustment, pull it a little tighter and test drive again, i have had this happen on several 700r4 on 2-3 shift, treadjusting cable took care of the problem everytime, sometimes it takes a few adjustments(little more tighter cable adjustment every time)

    good luck
     
  3. BigBurban350

    BigBurban350 1/2 ton status

    Joined:
    Jun 9, 2002
    Posts:
    711
    Likes Received:
    0
    Location:
    Michigan

Share This Page