Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

John Bull trail and break trouble??

Discussion in 'The Garage' started by midget, Apr 5, 2003.

  1. midget

    midget Registered Member

    Joined:
    Mar 2, 2003
    Posts:
    18
    Likes Received:
    0
    Location:
    California
    Just today after doing the John Bull trail here in SoCal my breaks were pulling real bad to the left when i hit the pavement again.. This has happened a couple other times after being on a trail,, it will last for about 30 min then will go away???? very strange. Otherwise they feel pretty good, dont really pull either direction.
    Today was just the same, after the 30 or so min everything started to feel ok again.
    Just wondering if anyone has ever had this happen and what it may be???
    I'm driving a /forums/images/graemlins/burb.gif with dana 60/detroit, TH400, np205, 10.5 14 bolt/detroit and 4.56 gears with 35's. Oh yea,, and a 454. Its a real pain in the 4ss driving down the hill after wheeling when they are doing this... /forums/images/graemlins/1zhelp.gif.
     
  2. rick88blaze

    rick88blaze 1/2 ton status

    Joined:
    Jan 24, 2003
    Posts:
    2,342
    Likes Received:
    1
    Location:
    Knob Noster, Mo.
    sounds like your caliper on that side is sticking when it gets warm on the trail. might see about changing it out for a new one or rebuilding that one.
     

Share This Page