Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

K20 Running High RPM's on Freeway

Discussion in 'The Garage' started by mendo, Oct 24, 2006.

  1. mendo

    mendo Registered Member

    Joined:
    Oct 22, 2006
    Posts:
    37
    Likes Received:
    0
    Location:
    Santa Barbara, CA
    My truck has a 350 and a bowtie overdrives stage II Tranny ( http://www.bowtieoverdrives.com ). 38x12.50 Swampers and 4:10's. It used to run at ~ 1700 RPM's on the freeway and then my brake booster went bad so I replaced it and now it runs at ~2400 RPM's on the freeway. Its like its not shifting into overdrive but I can feel it shift into all 4 gears. Any idea's on what happened? Thanks
     
  2. dremu

    dremu Officious Thread Derailer Premium Member

    Joined:
    Feb 27, 2000
    Posts:
    15,963
    Likes Received:
    454
    Location:
    East of San Francisco
    It sounds suspiciously like the mechanism for kicking into overdrive was disconnected or mis-adjusted when you did the booster swap.

    I know on the older transmission it was vacuum, but I believe on your newfangled crap it's electric ... I know you said you can feel all four gears, but it sure sounds like OD went away. I'd go checking the wiring around the booster, or down under on the tranny.

    -- A
     
  3. mudbog42

    mudbog42 1/2 ton status

    Joined:
    Jul 16, 2006
    Posts:
    452
    Likes Received:
    0
    Location:
    Florida for now
    Wow

    1700---2400, thats pretty good, I run at about 3000 RPM's:D on the highway with 35's and 4:88's:rolleyes:

    Sorry I couldn't help though:bow:

    but how do you like tranny from bowtie overdrives, I've been looking at them recently
     
  4. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    sounds like the converter clutch in not enguaging. that is vacuum operated up untill i think 88. you have to move it out of the way if not disconnect it to remove the booster. it probably is not hooked up.

    FYI every "gear" is hydraulic in a 700r4 and 4L60, no vacuum or computer controlls any shift. it does however controll the TCC which sometimes feels like another gear.
     
  5. makovai

    makovai 1/2 ton status

    Joined:
    Jun 6, 2006
    Posts:
    854
    Likes Received:
    0
    Location:
    oregon city
    vacuum, vacuum, vacuum. Check for vacuum leaks.....

    BTW i run 4:56 gears with 36x14.5 and do 3100rpm's on the freeway. dont feel so bad. coarse i get 7 mpg too. alot of it is the TH350 though
     
  6. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    X2 , and my year has the same setup , right next to the booster on engine side of booster .
     
  7. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Check your shift linkage. Maby when you pulled the booster you moved something or bent something. From your description it sounds like you are in D not overdrive [D]. If you are in drive (3rd) it will shift to 3rd gear and then the TC will lock up making it feel like a shift into 4th.
    Also check the TV cable adjustment. maby you knocked it out of adjustment when you changed the booster.
     
  8. beater_k20

    beater_k20 Banned

    Joined:
    Dec 9, 2003
    Posts:
    10,276
    Likes Received:
    0
    Location:
    Elkhart, IN
    interesting...
    with that RPM spread...
    2400 divided by 1700... that's .7
    your OD ratio is .7:1.
    coincidence?
     
  9. 6.2Blazer

    6.2Blazer 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    4,675
    Likes Received:
    26
    Location:
    Ohio
    The rpm difference is too big for it to just be the TCC not locking up. Locked to unlock the TCC should only make maybe 100-200 rpm difference, not 700 rpm. As already mentioned you are probably feeling the trans shift 1-2-3 and then the 4th thing you feel is the TCC locking in.......the trans is never shifting into OD.
     

Share This Page