Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Left blinker isn't working on the M1009

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Lotsa_Faith, Jun 25, 2002.

  1. Lotsa_Faith

    Lotsa_Faith 1/2 ton status

    Joined:
    Jul 10, 2001
    Posts:
    474
    Likes Received:
    0
    Location:
    Mckinney, Texas
    Left blinker isn\'t working on the M1009

    THe right blinker worked fine, but when you put on the left blinker it won't click and stay, itll just go down when you push it then right back up, even holding it down doesn't make the lights blink...anybody?
     
  2. txbartman

    txbartman 1/2 ton status

    Joined:
    Jun 1, 2001
    Posts:
    1,975
    Likes Received:
    0
    Location:
    Plano, TX
    Re: Left blinker isn\'t working on the M1009

    have you checked the fluid?

    /forums/images/icons/wink.gif couldn't resist
     
  3. Blue85

    Blue85 Troll Premium Member

    Joined:
    Jul 26, 2000
    Posts:
    9,084
    Likes Received:
    486
    Location:
    Grand Rapids area
    Re: Left blinker isn\'t working on the M1009

    Oh man, you beat me to it!

    Have you tried turning the steering wheel to different positions and trying it? Sorry to bring up the obvious, but it is normal for the blinker not to "stick" in certain positions every so many degrees. If there is no position that it sticks in, you may have broken the little plastic cam, which requires a fair amount of column disassembly to repair. I think that the repair part for this is avaiable in the "HELP" section of some car parts stores.
     

Share This Page