Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Lift problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 78k5, Sep 25, 2000.

  1. 78k5

    78k5 1/2 ton status

    Joined:
    Apr 25, 2000
    Posts:
    173
    Likes Received:
    0
    Location:
    Big Island, Va.
    I have a superlift 6" lift on my 78 k5 and the driver side spring sits crooked. It sits cocked to the inside of the axle like the bottom of the spring was pushed towards the passenger side. What could cause this?
     
  2. Espen88k5

    Espen88k5 1/2 ton status

    Joined:
    Feb 19, 2000
    Posts:
    981
    Likes Received:
    0
    Location:
    Norway
    I think the springs sit's on a "guidence-pin" on the springpad.. Never been there myself but maybe someone else. A jack to relive the tension and a good swing with a hammer???

    http://www.espen88k5.coloradok5.com
     
  3. Blue85

    Blue85 Troll Premium Member

    Joined:
    Jul 26, 2000
    Posts:
    9,092
    Likes Received:
    492
    Location:
    Grand Rapids area
    Here's some likely culprits:

    -Spring center bolt is not sitting in the hole in the spring pad. This is dangerous.

    -Sway bar is causing binding of everything (normal after a lift). Disconnect the sway bar from the axle and then adjust the spring/U-bolt/axle positioning.

    -Some spring bushings are junk or missing.

    I would suspect the first, since you shouldn't be able to get it together without the spring being lined up right. If that center bolt head is not in the locating hole, then the axle can move around under the truck even with the U-bolts tight. Yikes! Whatever the problem is, I would check it out ASAP.

    '85 JIMMY
    '90 paint/grill/trim 5"susp 33/12.5/16.5
    Fresh 350 B&M '87 TH700
     
  4. Rebel88

    Rebel88 1/2 ton status

    Joined:
    Sep 7, 2000
    Posts:
    1,855
    Likes Received:
    0
    Location:
    Richmond, VA
    When i put the lift on my 88 the center pin wouldnt line up right on the passenger side. It is a 6" superlift superride. I had to beat on it with a hammer till it was lined up but not quite in, then i torqued the u-bolts down and it pulled in. Dont know what the problem is but the driver side didnt do it. My blazer looked like the holes were different sizes in the spring perches from driver side to passenger. Maybe it was just me seeing through a cloud of red because i was ticked. After about 150 miles i unbolted the u-bolts and checked it and it is fine. Dont ask me.

    Have you driven OVER a Ford lately?
     

Share This Page