Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

lifter question ????

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by riz, Mar 21, 2001.

  1. riz

    riz 3/4 ton status

    Joined:
    Mar 7, 2000
    Posts:
    6,026
    Likes Received:
    0
    Location:
    Wisconsin
    <font color=purple> My friend has a 91 ? GMC truck and lately he said he's been hearing a ticking sound. The other day I heard it and it would increase with the higher idle and slow down as he would let off the gas. It sounds like it 's coming from under the valve covers so I would say it's a lifter. It doesn't do it all the time, just every now and then but not too long in between acting up again. What would be wrong with it ? Does it just need to have the lash set or is it sticking or what ? What should he do ? Please reply, I don't want to see something seriously go wrong with his truck. Thanks.

    L8r,
    . Riz . <A target="_blank" HREF=http://www.geocities.com/rizmonkey>http://www.geocities.com/rizmonkey</A>

    [​IMG]
     
  2. Pugsley

    Pugsley 1/2 ton status

    Joined:
    Jan 16, 2001
    Posts:
    3,556
    Likes Received:
    0
    Location:
    Tucson, Arizona
    Sounds like one's clogged. It might be worth the relatively few bucks it'd take to run Motor Flush or some such through it and see if it goes away.

    [​IMG]
     
  3. lowlevell

    lowlevell 1/2 ton status

    Joined:
    Jun 27, 2000
    Posts:
    343
    Likes Received:
    0
    Location:
    Central Ohio, USA
    My 89' 350 is doing the exact same thing. 190,000 miles. When it ticks, it usually does it when i restart my truck.(like after i run into the store for a sec). It doesnt do it all the time, about once a week. And it only last for about 2 min. I pulled my drivers side valve cover off and pulled the rear two rockers and pushrods, but they were fine. I believe it is a sticky/clogged lifter. ( even though the inside of my engine is spotless). Im hoping it will just work itself clean. Im not pulling that friggn manifold off for one sticky lifter:) Later....

    One From None
     

Share This Page