Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

light/turn signal ???

Discussion in 'The Garage' started by Pow06er, Apr 21, 2005.

  1. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    Ok when i put on right turn signal the light in the dash just turns on doesnt do nething.

    outside nothing happens on the right side....when i put on the brakes the back right rear light doesnt work.

    But the lefts are all fine and work and blink properly.

    Could i have messed something up when i put in my deck or should i replace the bulbs?

    I think im gonna do the bulbs 1st since its easier.

    has ne1 ever heard of this?
     
  2. RaisedK5

    RaisedK5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    932
    Likes Received:
    0
    Location:
    Long Beach, CA
    burned out bulb, the flasher works by using a bimetalic strip, when the amp draw of all the light bulbs heats up the strip it bends away from teh contact and the bulbs go out, then when it cools donw it bends back and makes contact, the bulbs go on, then it heats up agains and bends away, and the bulbs go out, then on then off then on etc. if a bulb burns out, the remaining bulbs will not draw enough current to heat up the flasher strip enough to bend away, thus the lights dont flash. replace that tail light and i'm sure it will be back to normal.
     
  3. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    Ok this might sound insane and if you have the same problem I had, I will be amazed? Did you say you installed a new stereo deck in your dash?

    Cause my left rear blinker was out, but the parkings worked. bulb was fine. Finally got around to looking at it and I was in my shop and tapped my brakes and saw the brake lights didn't work I started looking around in the wire mess under my dash and there are two little push button switches for my brake lights on your brake pedal and one of the switches had some wires stuck infront of it. I zip corded the wires away from it and my blinker worked again and as well my brake lights... how stupid and insane?

    Hope you have a similiar problem cause its an easy fix ;)
     
  4. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    im gonna go search now cuz the lights seemed to have been working and now not

    i did move some wires when i removed the ac tube to get to the headunit...
     
  5. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    ok i dunno I went out in the rain for a quick look over and heres wat i have ..

    for one the right rear tail light is burnt out. I was unable to find the wires under the pedals a pic might help because theres a lot of wires and i probably missed something.

    Heres wat i did i turned the lights on all the front lights are working headlights, side markers, and parking lamps behind grille. Wat i did was i removed the left tail light and put it into the right tail light and hit the blinker and still nothing at all... just get the dash turn signal light stays on and the rear blinker doesnt blink and the front parking light and side marker just stay on.

    Wat could be the problem?

    I notice that when i turn on my lights that the right turn signal lights up and I dunno wat that does... In the mean time I'm gonna get new rear bulbs and backup lights and see wat that does. If someone could get a pic of under there pedals. anymore info on what affects the turn signals would be nice.

    thanks

    Paul
     
  6. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    First what year your rig? I dont know if the buttons for the brake lights is the same in all years, My truck is an 85 and if you fallow your brake pedal up you'll see two plastic buttons touching the pedal, and which you push the pedal they are released and not touching the pedal. Well what happened for me is I got some loose wires infront of one of these buttons so it was always staying pushed and it kept my brake lights from working and my right rear turn light. But when I moved them out of the way so the button could work normal, it was fine.
     
  7. dirtwarrior17

    dirtwarrior17 Banned

    Joined:
    May 14, 2004
    Posts:
    1,820
    Likes Received:
    0
    Location:
    Redding, CA
    sounds like the button but it could also be the cam inside your steering colum... those things are flimpsy as hell.
     
  8. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    its a 88... COuld it be a fuse

    I noticed that my flashers dont work either... and ill look for the brake plug again

    if its in the steering column wouldnt it still blink ???

    I dunno pretty confusing
     
  9. dirtwarrior17

    dirtwarrior17 Banned

    Joined:
    May 14, 2004
    Posts:
    1,820
    Likes Received:
    0
    Location:
    Redding, CA
    gotta be the fuse...

    when i bought my 88 it had one blinker working, changed the fuse and they both worked.

    the cam in the steering colum IIRC is the switch that completes the blinker circuit so if it is gone it shouldn't blink(that is if both signals are broken, if one is broken on the cam then only one will work) but i'd bet my truck its the fuse.
     
  10. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    does anyone know which fuse it is??? I dont have a manual or anything
     
  11. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    ok update: Installed new tail light bulbs and reverse bulbs, Installed new turn signal flasher

    almost got it except now ..... I must need a new bulb in the turn signal behind the grille because it is not blinking but it comes on when i turn on the lights and im still getting the light on my right turn signal to say that theres a turn signal out so... Im off to autozone again

    but after installing the new flasher all the lights are flashing cept the front right one.. the old flasher had a little dent in it..
     
  12. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    ok i got it turns out that the front right bulb was coming apart I had to bend my billet grille very carefully not to break anything to get out the light. darn billets anyways I fixed it thanks for all your help

    btw i bought myself a repair manual at autozone.
     
  13. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    Cool, that you finally got it all fixed
     
  14. Pow06er

    Pow06er 1/2 ton status

    Joined:
    Apr 9, 2005
    Posts:
    188
    Likes Received:
    0
    Location:
    ne, ohio
    yea cept the reverse lights arent working but thats alright I plan to mount some fog lights back there and run a switch so...
     

Share This Page