Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

loud bang under my feet.???gurus click here??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bklynlifted, Apr 14, 2002.

  1. bklynlifted

    bklynlifted 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    261
    Likes Received:
    0
    Location:
    brooklyn ny home of the brave
    okay ive got this noise under my feet when hitting a bump in the road also when starting from a stop ? ive eliminated the following steering , shocks, wheel bearings motor mounts,the exhaust, front suspension., the trans mount looks ok but i am replacing that anyway . it feels like a someone is hitting my floorpan with a hammer real fast ? body mounts are ok. univesial joints on main drive shaft are new? i have a 4inch lift with transfercase drop??? any help yu guys can give would be helpfull cause i live in ny and there are lots a potholes so this bangin is there all the time and IS PISSIN ME OFF. thanks guys.
     
  2. KRAZIE87K5

    KRAZIE87K5 1/2 ton status

    Joined:
    Feb 23, 2001
    Posts:
    3,369
    Likes Received:
    0
    Location:
    Chicago, IL
    Check the rear shackle bushings on the front springs... particularly the ones inside the frame rail, inside the "housing." MIne are shot, and they have the same effect on bumps. I bought the ORD greaseable HD front shackles to fix the problem... they come with new poly bushings. Good luck!

    http://offroaddesign.com/catalog/hdshackles.htm
     
  3. bklynlifted

    bklynlifted 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    261
    Likes Received:
    0
    Location:
    brooklyn ny home of the brave
    thanks for the reply dan i'll check that out and let you know if thats my problem it realy sucks changing all these parts and still have this wacking noise under your feet . if it was on the passenger side i would't give a rats ass thanks . jack
     
  4. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,063
    Likes Received:
    71
    Location:
    Pleasanton, CA.
    Let me know if you find the problem, I have the same problem. I can here and feel the noise when I start and stop and also when I go over bumps or potholes. I have already looked at everything you have plus my frame shackle bushings and still haven't figured it out. When I first bought my blazer in August it did not make any of this noise or thump, it just started one day and has been getting worse ever since. On a good note, I guess it will eventually get so bad that I will be able to find it. LOL
     
  5. could be the floor pan flexing when you hit a pump or talk off and the load shifts to the rear. ever had your roof pop when wheelin? i think it might be a similar kinda thing.
     
  6. bklynlifted

    bklynlifted 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    261
    Likes Received:
    0
    Location:
    brooklyn ny home of the brave
    ive checked the shackle bushings they look ok also i dont think its the floor pan it feels like the exhaust hitting the floor pan but ive checked that and its not movin I'M STILL STUMPED . THANKS FOR THE REPLYS KEEP EM COMING ? thanks
     
  7. KRAZIE87K5

    KRAZIE87K5 1/2 ton status

    Joined:
    Feb 23, 2001
    Posts:
    3,369
    Likes Received:
    0
    Location:
    Chicago, IL
    I'd next blame the "captured" nuts for the body mounts. Have you ever replaced the body mounts on your truck? Is it possible that your bolts have pulled thru like mine did? I have a really clean body... but when I was at Disney, I managed to pull thru 2 body bolts which then started a clicking-clunking kinda noise on the passenger's side. The original mounts in my truck had became too soft, and allowed the body to flex up like mad...

    Just another idea....
     
  8. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    Is it engine related, or suspension related? (I'm unsure from the post)

    Does the noise occure when the engine is torqued, can it be duplicated by "power brakeing"?
    Power brakeing (one foot on the brake, one foot on the gas) will load the engine, it might also be helpfull to "pop" the throttle, inorder to duplicate the noise.

    Or is it strickly suspension related, regardless of engine/throttle in-put. Can or could you duplicate it with the trans in neutal or coasting over a ruff road?

    Determining what system is "in operation" when the noise ocures could help to zero in on the problem.
     
  9. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Check for a broken floorpan
     
  10. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Sorta sounds like a busted body mount and the body is bouncing. I have seen buckles in the floor make a bonking sound also.

    I know you say its on the drivers side (you said something about wishing it was on the pass. side) but the only thing I see you havent checked is the header to shackle bolt clearance, on the passengers side. It could be hitting and the sound is transferring thru. My exhaust runs close to but not touching the Tcase brace, and it will vibrate and make a ticking sound as I am taking off. As well as my header flange being close to the shackle bolt and clipping it occasionally.
     
  11. Zeus33rd

    Zeus33rd Smarter than you GMOTM Winner

    Joined:
    Mar 14, 2002
    Posts:
    7,324
    Likes Received:
    9
    Location:
    Grass Valley, CA
    LOL.......I get the roof popping noise when wheelin too. HA! ANyways, I have a similiar noise in my front end. But I know what it is. My sway bar busing are SHOT> Basically just not any rubber left. They rattle around alot. One of these days I'll replace them.
     
  12. ntaj*ep

    ntaj*ep 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    3,248
    Likes Received:
    1
    Location:
    Evergreen state
    I agree with Twiztid, is this a rythmic pop while driving or unrelated to engine/drivetrain just sitting you can duplicate.
     
  13. bklynlifted

    bklynlifted 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    261
    Likes Received:
    0
    Location:
    brooklyn ny home of the brave
    thanks for the replys . if i hit a dip or a bump or a pot hole in the road the rattling under my feet seems to happen when my drivers side front wheel hits the road (bump pothole ) anything . if i hit the same tpe road hazzard with the passanger side front wheel nothing no rattling or banging at all. i have changed 2 body bushings under the radiator support ive checked the leaf spring bushings upper and lower and they are ok alos checked the body mounts under my feet and are ok. ive checkedwheel bearings etc . STILL STUMPED. KEEP THOSE SUGGESTIONS COMING. THANKS GUYS . THERE isn't ANY 4 wheel drive shops that i know of in the ny metro area to check out my rig. $$$$ got cash but no place to spend it on a fix? or a diognosis PS when i take off from a stop and goose the gas pedal i will feel a fluddering under my feet so whatever is making that happen is directly related to the problem when i hit a road hazzard???
     
  14. MRBIGBLOCK

    MRBIGBLOCK 1/2 ton status

    Joined:
    Jun 25, 2001
    Posts:
    472
    Likes Received:
    0
    Location:
    paragould arkansas
    i think that you RAN OVER a jeep, could have been a bronco, ya better check your tires for poop marks, that will tell the story.
     
  15. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Check your tansfer case mount...probably the same as the tranny mount. Make sure it is bolted down. Someone decided mine didn't need bolts and I had the same problem.
     
  16. bklynlifted

    bklynlifted 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    261
    Likes Received:
    0
    Location:
    brooklyn ny home of the brave
    checked the trans mount and it looks ok but im changing it in a day or two got 1 on the way from 4wp. i figure ive changed most everythig i can so far its just a matter of time and i'll find the problem? maybe i'll get lucky and something will break and then i'll know for sure??? thanks for the reply. ps changed a 2footX2foot section of floorpan on the drivers side last month andstill got the same problem??? back to the grind tomorrow between the drought in ny and the clean up at W.T.C i'm real busy and don't have much time to work on my truck.
     
  17. 89Blazin

    89Blazin 1/2 ton status

    Joined:
    Mar 20, 2001
    Posts:
    134
    Likes Received:
    0
    Location:
    midwest KC area
    Sure sounds like a bad left side front shock...I know you checked them...but....
     
  18. bklynlifted

    bklynlifted 1/2 ton status

    Joined:
    Feb 4, 2002
    Posts:
    261
    Likes Received:
    0
    Location:
    brooklyn ny home of the brave
    new shocks installed 4 weeks ago procomp 3000's. just got my tranny mount ( thanks bigredblazer ). i'mm going to install it and see if thats the PROBLEM STAY TUNED .thanks for the reply
     

Share This Page