Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Loud popping and grinding while turning...LSD???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ftn96, Apr 26, 2001.

  1. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    I had just installed my Auburn Pro series LSD in my rear 10 bolt nad all was good for the first 1500 miles or so, and one day while I was making a slow sharo turn I started hearing all this popping and grinding going on. So I got under there and had my dad turn in circles and the hole pinion yoke and driveshaft was racheting as it turned while all this noise was coiming from the Pumpkin.
    After inspecting the gears, axles, bearings, pinion, the whole nine yards I found nothing to be wrong. And again this only happend while turning. nothing while going straight. So it has to be the LSD right? Yes I added the additive.
    What would cause this thing to do this? Or is that what to expect from a pro series LSD? I haven't heard lockers make that much noise....
    Anyways Jegs has replaced it. Im just hoping my problem is going to be gone.

    Will work for beer, parts and tools.
    90-350TBI-TCI700-241-33"-10/12 bolt w/4.10's,
    <A target="_blank" HREF=http://www.nashvillek5.freeservers.com>http://www.nashvillek5.freeservers.com</A>
     
  2. 6.2Blazer

    6.2Blazer 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    4,675
    Likes Received:
    26
    Location:
    Ohio
    I've seen some aggresive limited slips have kind of a "chatter" when going around corners, but the grinding and popping noise does not seem normal at all. My guess is that some part of the limited slip failed, even if it was not visible.
     
  3. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    Thats what I was thinking, but the thing that bothers me is that I haven't even been off-road in the damn thing since I installed. Havn't abused it at all. Just normal everyday driving.
    I cant seem to find any visable damage, but like you said maybe its in there where you cant see it.

    Will work for beer, parts and tools.
    90-350TBI-TCI700-241-33"-10/12 bolt w/4.10's,
    <A target="_blank" HREF=http://www.nashvillek5.freeservers.com>http://www.nashvillek5.freeservers.com</A>
     
  4. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    i have a 12bolt rear with lsd and mine makes no noise so i would say that it is not normal

    77blazer see it at<A target="_blank" HREF=http://community.webshots.com/user/ssmith6333>http://community.webshots.com/user/ssmith6333</A>[​IMG]
     
  5. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    So far Jegs has had no problem replacing it. I have to send the old one back so they will credit my card. I have also dropped a line to auburn to see if they have any thing to say (doubt it).
    I dont even want to say this, but is there anyone who has ever had anything like this happen and found out it was something from the t-case?

    Will work for beer, parts and tools.
    90-350TBI-TCI700-241-33"-10/12 bolt w/4.10's,
    <A target="_blank" HREF=http://www.nashvillek5.freeservers.com>http://www.nashvillek5.freeservers.com</A>
     
  6. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    addition, this $hit was load enuff that my wife could here it from 50 feet away.
    I dont think lockers make that much noise. So somehting is definaetly wrong. But I hope all it is is just a bad apple.

    Will work for beer, parts and tools.
    90-350TBI-TCI700-241-33"-10/12 bolt w/4.10's,
    <A target="_blank" HREF=http://www.nashvillek5.freeservers.com>http://www.nashvillek5.freeservers.com</A>
     
  7. K5Jimmy

    K5Jimmy 1/2 ton status

    Joined:
    Sep 21, 2000
    Posts:
    1,141
    Likes Received:
    0
    Location:
    Lake Dardanelle/Logan Co, Ark
    I have an Auburn Pro in my 12B with Moser 1340H axles.....also got the Pro in my 10B front.....I use 14oz of LSD additive in the rear, and still get a bit of chatter especially after runnin' it at highway speeds and then slowing down...been this way since I installed it a little over 3 yrs ago....going from 7oz to 14oz helped a bit, but I still run 7oz in the front and have no noise from that end......the Auburns grip like a B*tch in the mud and loose stuff.....the chattering has gotten worse over time, but still doesn't seen to affect performance....I think if I had it to do over again, I'd go with the 800lb spring upgrade on the Eaton since it's rebuildable....the Detroit is a little overkill for my application since I run my truck such long highway trips (2500M +)...the LSD is also easier on a C-clip s'pecially since I don't feel the need for a 14B or a D60....I can go pretty much where I want and still get me back home....I got no plans to run the Rubicon.....just one man's opinion.....JD

    I'm at 10th and Plum....10 miles from nowhere, and Plum out in the sticks....Stuck?...Hell no..I still got some gas left..
     
  8. JIM88K5

    JIM88K5 1/2 ton status

    Joined:
    Apr 27, 2001
    Posts:
    1,384
    Likes Received:
    0
    Location:
    Vancouver, Wa
    If you have lift blocks like I do,they may be walking around.
    Loosen & re-tighten your u-bolts.My creaky old ship noise
    will go away for a few days when I do this.My cure is my
    ORD shackle flip that now rests on my work bench.
     
  9. BUDDY

    BUDDY 1/2 ton status

    Joined:
    Apr 28, 2000
    Posts:
    744
    Likes Received:
    0
    Location:
    Midland, TX
    Just one more suggestion. Check your front axle u-joints. Mine were bad a few years ago and they popped and clanked around so bad I didn't know what to think. Plus, they're a whole lot easier to fix than the diff is.

    HTH,

    Buddy

    72 K-5, 33x12.5's, 350/350/205,12-bR,d44F soon to be 39.5'x15.5s, EFI502/nv4500/doubler205, d60F, d70R. Stay tuned.
     
  10. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    I have new front axle joints adn lift SPRINGS all the way around. No block here.
    I was running only 7 oz. of additive. And as far as the Pro's hooking up, I was at friends house with a huge dirt pile and I drove up it nad once the other tire started coming off the ground I was still going forward. SO I will have to testify to the fact that they lock up good. But there is absolutly no reason they should be making the noise I was getting. We'll see though, I have the new one at home. I already swaped out the ring gear. I will get the rest of it put back together tonight hopefully. But I get my son this weekend. So I may be delayed a bit. I'll let you all know if the sounds go away after installing the new LSD.

    Will work for beer, parts and tools.
    90-350TBI-TCI700-241-33"-10/12 bolt w/4.10's,
    <A target="_blank" HREF=http://www.nashvillek5.freeservers.com>http://www.nashvillek5.freeservers.com</A>
     

Share This Page