Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

LOUD sqweel from a/c comp. i think...anybody had this happen???

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 01maroonz71, Jan 26, 2007.

  1. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    well, my a/c blows cold on my 83 K10...but when the compressor is on...it sqweels really loudly when i give it gas(ie. driving around) but at idle it doesn't do this at all....could this be the belt is bad or would it be something internal in the compressor/clutch??? also....this is the belt that goes from the fan to the compressor to the PS pump...so it runs 3things....anybody got a clue????
     
  2. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    belt is too loose , even if you think it is tight . You can tell by squirting some silicone or belt drssing on it and watch it go away temporarily .
     
  3. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    well...i tried the bar of soap trick....didnt work...

    also tried the toothpaste trick(to get rid of glazing) didin't help either...

    i will try silicone...i think im just going to replace the belt and see where im at. thanks a bunch ya'll!!!!
     
  4. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    well...there is a new problem now...when i turn on the a/c..it smells like something is on fire or burning and the stench fills up the cab quickly...smells like burning rubber...no good.
     
  5. cbbr

    cbbr 1 ton status GMOTM Winner

    Joined:
    Jul 17, 2004
    Posts:
    14,681
    Likes Received:
    0
    Location:
    High velocity, Low altitude
    Does it smell like a burning belt? Replace the belt and tighten it up.
     
  6. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    10-4...haha...i was hoping thats what it was....ill get er done tomm. i can't wait to go serpentine.
     
  7. cbbr

    cbbr 1 ton status GMOTM Winner

    Joined:
    Jul 17, 2004
    Posts:
    14,681
    Likes Received:
    0
    Location:
    High velocity, Low altitude
    My OBA belt is doing the same thing. At least its a small PITA.
     
  8. 79Beast

    79Beast 1/2 ton status

    Joined:
    Dec 9, 2001
    Posts:
    1,155
    Likes Received:
    0
    Location:
    Georgia
    Take a close look at the alternator belt. I've seen it lots of times that people think the A/C belt is loose because it only squeals when the A/C is on, but the additional electrical load will make a loose alternator belt squeal...at it will happen at the same times as a A/C belt could squeal.
     
  9. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    Probably belt squeal, but could be the compressor starting to lock up.
     
  10. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    well, i replaced all 3 belts today, since they're so cheap and i had to pull one off just to get the a/c belt off i figured what the hell...and it cured the sqweel...thanks for you help guys!!!! and now i have 3 spares incase one of these gives way!
     

Share This Page