Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

low end power question

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by tecton, Jan 18, 2004.

  1. tecton

    tecton 1/2 ton status

    Joined:
    Dec 1, 2002
    Posts:
    1,553
    Likes Received:
    0
    Location:
    WV
    i notice this alot when in OD...

    from about 1000rpm to 1500rpm, if i stomp the gas...it wants to loaf, hesitate, call it what you will, til it gets up to about 1700-2000 then it starts taking off.

    Im wondering if my truck has a problem, something with the carb mabye? Or is this normal.
     
  2. joez

    joez 1/2 ton status

    Joined:
    Oct 21, 2003
    Posts:
    2,512
    Likes Received:
    0
    Location:
    New Lenox, Illinois
    does it downshift?
     
  3. Z3PR

    Z3PR Banned

    Joined:
    Mar 30, 2002
    Posts:
    19,217
    Likes Received:
    0
    Location:
    Everywhere
    Does it do the same thing in "D" ???
     
  4. tecton

    tecton 1/2 ton status

    Joined:
    Dec 1, 2002
    Posts:
    1,553
    Likes Received:
    0
    Location:
    WV
    yeah, the gear or speed doesnt matter so much, ist just im usually more likely to be driving down the road at that rpm while in od...but its at any gear, any speed just that rpm range...the downshift wont happen til it climbs up in rpms
     
  5. SUBFAN

    SUBFAN 1/2 ton status

    Joined:
    Mar 23, 2003
    Posts:
    2,334
    Likes Received:
    0
    Location:
    Davenport, Ia
    I would look into the TV cable adjustment....
     
  6. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    I'm far from a carb guru, but it sounds to me like you have a problem with your secondaries opening properly.

    Maybe someone who actually knows about this will post up. /forums/images/graemlins/rotfl.gif
     
  7. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    Sounds like you're slow on timing or your advance weights are stuck.

    Could also be a vacuum issue with your secondaries as well, as mentioned above.

    Every Q jet I've ever driven had a mild bog as the secondaries opened though.
     
  8. rjfguitar

    rjfguitar 3/4 ton status GMOTM Winner

    Joined:
    Aug 28, 2002
    Posts:
    9,096
    Likes Received:
    144
    Location:
    california
    Yeah, carb secondaries or timing.
     

Share This Page