Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Low Oil Pressure, please help!!!

Discussion in 'The Garage' started by dawson444, May 4, 2003.

  1. dawson444

    dawson444 1/2 ton status

    Joined:
    Jul 5, 2000
    Posts:
    1,034
    Likes Received:
    0
    Location:
    Raleigh, NC
    My oil pressure is a lot lower than normal. Normally it hangs out around 60, now it is getting well below 30.

    Anyone have any tips on whats up? I did just have the engine out to replace one of the pistons. But for a while the pressure was fine. I just changed the oil today, but that didn't bring it up.

    I have the 2 oil pressure senders on mine, one by dist. other by oil filter. Is it possible to read the pressure off the one that is not for the gauge? Thanks!
     
  2. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    One will be for the gauge and one for the "dummy light" Normal PSI when hot and at idle (IIRC) is ~ 10 psi.

    You're still good. Did you put in a new oil-pump? A HD or big-block pump?

    I get ~60 PSI when cold and ~ 30 psi when all warmed up.

    What weight oil are you running? It won't matter but ~10 psi anyway- But I thought I would ask.

    Good luck.
     
  3. dawson444

    dawson444 1/2 ton status

    Joined:
    Jul 5, 2000
    Posts:
    1,034
    Likes Received:
    0
    Location:
    Raleigh, NC
    I didn't put in a new pump, the engine was a GM crate engine and had 5k miles on it. I am running 10w30 in it. What gets me is it used to always hang out around 60, and now it is well below 30. If I put numbers in where i would guess they would go, it is getting down to around 10. That worries me. I'm not sure if it is the sending unit or what. Anyone have any ideas?
     

Share This Page