Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Master cylinder bad?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by JOEDEZZY, May 6, 2006.

  1. JOEDEZZY

    JOEDEZZY 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    155
    Likes Received:
    0
    Location:
    TUCSON, AZ
    When I'm in drive or reverse letting the truck move while idling, I apply my brakes, sometimes they grab sometimes they go straight to the floor. When I accelerate the brakes grab every time I hit them. I've checked my brake shoes and pads, they're in good shape, there is no signs of leaks any where and the master cylinder is full. I did have a vacum leak on my brake booster but I fixed that, I have no idea what could be causing this, any thoughts?
     
  2. JOEDEZZY

    JOEDEZZY 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    155
    Likes Received:
    0
    Location:
    TUCSON, AZ
    also when I am in drive and apply the brakes, after sitting there for a minute or 2 the brakes will slowly go to the floor.
     
  3. JOEDEZZY

    JOEDEZZY 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    155
    Likes Received:
    0
    Location:
    TUCSON, AZ
    never mind, i fixed it
     
  4. AZ79K5Project

    AZ79K5Project 1/2 ton status

    Joined:
    Jan 15, 2006
    Posts:
    2,082
    Likes Received:
    0
    Location:
    Arizona
    What did you find? Just curious.
     
  5. JOEDEZZY

    JOEDEZZY 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    155
    Likes Received:
    0
    Location:
    TUCSON, AZ
    The master cylinder was bad, the plunger in there wasnt holding presure all the time, it was just weird because there wasnt any fluid leaking.
     

Share This Page