Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Missing Non-U Bolt Stud

Discussion in 'The Garage' started by ARAMP1, Feb 9, 2006.

  1. ARAMP1

    ARAMP1 Aviator Extraordinaire

    Joined:
    Sep 1, 2005
    Posts:
    3,983
    Likes Received:
    55
    Location:
    Memphis, TN
    I just realized tonight that I am missing the stud that is on the passenger side of the front Dana 60 axle that holds the spring on. It doesn't have the normal U bolts. They are some type of stud and I can't find anything online. Think NAPA will have them? If not, where would I get it?

    DSC02288.JPG
     
  2. readymix

    readymix 3/4 ton status

    Joined:
    May 30, 2004
    Posts:
    6,706
    Likes Received:
    26
    Location:
    Murrieta, California
    Get a 5/8-11 Grade 8 bolt in the correct length. Most are 2 3/4" - 3" long depending on how think your spring pack is.
     
  3. ARAMP1

    ARAMP1 Aviator Extraordinaire

    Joined:
    Sep 1, 2005
    Posts:
    3,983
    Likes Received:
    55
    Location:
    Memphis, TN
    I guess there's nothing special about it, is there? Thanks Chief!!!
     
  4. readymix

    readymix 3/4 ton status

    Joined:
    May 30, 2004
    Posts:
    6,706
    Likes Received:
    26
    Location:
    Murrieta, California
    Nope, just a standard G8 5/8 x 11
     
  5. nvrenuf

    nvrenuf NONE shall pass! Premium Member

    Joined:
    Jan 7, 2002
    Posts:
    13,074
    Likes Received:
    245
    Location:
    Mobile, Al.
    Check the hole and make sure the stud isn't broken off in there.
     
  6. ARAMP1

    ARAMP1 Aviator Extraordinaire

    Joined:
    Sep 1, 2005
    Posts:
    3,983
    Likes Received:
    55
    Location:
    Memphis, TN
    Thankfully it isn't broken off. It's completely gone. (Damn death wobble)
     

Share This Page