Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

motor mounts?!?

Discussion in 'The Garage' started by cannibal, Jul 24, 2003.

  1. cannibal

    cannibal Registered Member

    Joined:
    Mar 13, 2003
    Posts:
    56
    Likes Received:
    0
    Location:
    Amman, Jordan
    heya all,

    i have a problem, after a few hard offroad hang outs my motor mounts are dead, yesterday the fan started hitting the metal frame underneath it, i checked it out today with a mechanic friend and said that the mounts need changind' anyway, due to the lack of stores around here" maybe im the only one here who is interested in really what a blazer is meant to be, others use it as a normal ride (crap)" neway, the [point is the only dealer of original parts are Acdelce around here, so what do u think, i might do this saterday. thanksss...
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    If your fan is hitting metal, you may actually have cracked braces that the motor mounts bolt to. Not sure if you can see this with the engine in the truck, but you need to find out if this is what is causing the problem, or part of it.

    Pretty common for that piece to crack, and as it does, the front of the engine (and probably the rear) drops. My dads was this way, the harmonic balancer got closer and closer to the frame until it started rubbing. /forums/images/graemlins/smile.gif
     

Share This Page