Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

MSD people, truck wont start

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by PetaKane, Sep 19, 2002.

  1. PetaKane

    PetaKane 1/2 ton status

    Joined:
    Apr 17, 2002
    Posts:
    530
    Likes Received:
    0
    Location:
    Oklahoma City OK
    Truck is getting fuel just no spark. I've got an MSD 6AL box, Blaster 2 coil and here is my problem. The truck will not start unless the 12V switched wire is connected to a constant 12V source, then it'll run for a few seconds and die again. When I connect it to a 12Switched source, it'll crank and crank and crank but won't fire up. I've checked my 12Switched sources with Multi-meter and they are just fine. I'm scratchin my head on this one, does my truck just want me to kill it?
     
  2. 76chevy

    76chevy 1/2 ton status

    Joined:
    Aug 16, 2000
    Posts:
    246
    Likes Received:
    0
    Location:
    Utah
    Have you tested the coil? I'm not sure but I think Greg72 had this problem a while back. Find out more though before you go buy a new coil. Wish I could help more.
     
  3. fr8train

    fr8train 1/2 ton status

    Joined:
    Aug 2, 2000
    Posts:
    1,712
    Likes Received:
    0
    Location:
    Maryland
    PM or email Philly87....he's a MSD tech guy.
     
  4. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    Ditto on that. He has helped me out alot over the last year or so. Also on the MSD website there are ways to troubleshoot, and ways to test to see if the box is bad.
     

Share This Page