Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

My 72 K-5 (couple people told me to post on this board instead)

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 72K5BEAST, Jan 2, 2002.

  1. 72K5BEAST

    72K5BEAST Registered Member

    Joined:
    Dec 28, 2001
    Posts:
    15
    Likes Received:
    0
    Location:
    Oklahoma
    Hello everyone, a couple of people told me to post my question on this board instead of the 69-72 board because this one moves much faster. So i hope you all don't mind. Anyway, on to my problem... Ok, when i start my car sometimes the car dies after about 3 seconds of idling (i'm giving it gas but it still dies). Then i'll try again and it'll die again. Then the third time it'll die almost immediately. After that... it won't start anymore for awhile. What's the deal?

    And i have another problem... when i turn the engine off it sputters and clunks around for a little bit. Any idea what could be causing this?

    Well, thanks everyone for the help and thanks for even taking the time to read this.

    Later everyone,
    Charlie
     
  2. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
  3. zakk

    zakk 1/2 ton status

    Joined:
    Sep 21, 2001
    Posts:
    4,762
    Likes Received:
    0
    Location:
    San Jose CA
    will it run at all once it is warm? Does it "stumble" or feel like it is losing power when you step on it??

    -zakk

    '77 1-Ton K5

    [​IMG] CK5's MOAB 2002 OR BUST!! [​IMG]
     
  4. NeutralMan

    NeutralMan Registered Member

    Joined:
    Jan 2, 2002
    Posts:
    15
    Likes Received:
    0
    Location:
    vancouver bc canada
    i had close to the same problem it turned out to be a flooding carb in morning ran like trash after the 3 rd or 4 th time i try to start it , it would be flooded and i'd have to wait for it to dry out if it is this you will smell raw gas .
    and to fix you'll have to replace or rebiuld carb
    have fun if it a rodchester quad jet
     
  5. ChevyCaGal

    ChevyCaGal 3/4 ton status

    Joined:
    Dec 16, 2000
    Posts:
    8,158
    Likes Received:
    0
    Location:
    Sacramento, CA USA
    For the starting up... I'd check out the carb to see if the choke was working correctly... like if it's opening up all the way. Mine did something sort of like that. What kind of carb do you have in there? Is this when cold starting?

    On the second part the clunky sputtery engine I say check out the floats levels on the carb... sounds like that could be causing you the trouble there....

    &lt;&gt;&lt;<a target="_blank" href=http://www.chevycagal.homestead.com/steph.html>Steph's Webpage</a>&gt;&lt;&gt;
    Suck Fumes Ford Boy
    I'm in shape.... round is a shape......
     
  6. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    Problem 1 - either fuel pump is weak, fuel filter clogged, or the floats sticking. Fuel filter is inside the carb (assuming you have a Q-jet).

    Problem 2 - sounds like dieseling - either timing is advance too much or idle is too high. Does it do this 'sputter and clunking' if you shut if off in gear?



    <font color=blue>'79 ONE TON TPI K5 - See it at---&gt;<a target="_blank" href=http://www.blazzinor.rockcrawler.com>www.blazzinor.rockcrawler.com</a>
     
  7. muddin4fun

    muddin4fun 3/4 ton status

    Joined:
    Feb 19, 2001
    Posts:
    5,644
    Likes Received:
    0
    Location:
    N Texas
    I know exactly what you're problem is:
    <blockquote><font class="small">In reply to:</font><hr>

    Ok, when i start my <font color=red>car</font color=red> sometimes the <font color=red>car</font color=red> dies

    <hr></blockquote>

    Don't call them a car. They hate that [​IMG]

    Seriously though, I agree with BlazzinOR

    When was the last time you did a tune up?

    <font color=blue>Answers: $1, Short: $5, Correct: $25, dumb looks are still free.</font color=blue>

    <a target="_blank" href=http://www.bluefox.tv/~lara>My Wonderful Site</a>
     
  8. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    mine goes the same but if I turn it off in gear no problems,what that about?????
     
  9. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
  10. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Thank you that is the first thing on the list for sat morning # 2 is trying to get all the adjustments done on the rodchester so I can go play at hollister the next weekend again thanks
     

Share This Page