Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

My 92 wont start! computer related

Discussion in 'The Garage' started by deek, Apr 2, 2005.

  1. deek

    deek 1/2 ton status

    Joined:
    May 6, 2003
    Posts:
    142
    Likes Received:
    0
    Location:
    Great Bend, KS
    One day my truck wouldn't start, I have spark & fuel pressure all the way up to the TBI but theres no voltage to the injectors, so theres no fuel comming out.. I replaced the computer & it seemed to fix the problem but only for a day, I drove around town for about 6 hours then all of a sudden it just wouldn't start that evening. what could be causing this? I really don't want to keep burning up ECU's.
    If its going to be to confusing Im thinking about slapping on a carb (last resort).
     
  2. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    did you check to see if you are getting voltage to the injectors. Use a test light pluged into one of you injector conectors and have somebody crank it if the light blinks on and off your problem lies with the injectors them self. Als are you getting any DTC codes?
     
  3. deek

    deek 1/2 ton status

    Joined:
    May 6, 2003
    Posts:
    142
    Likes Received:
    0
    Location:
    Great Bend, KS
    No voltage & no codes :frown1:
     
  4. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    did you check all the fuses? Also where did you get the new ECM from?
     
  5. deek

    deek 1/2 ton status

    Joined:
    May 6, 2003
    Posts:
    142
    Likes Received:
    0
    Location:
    Great Bend, KS
    fuses are good,, & the ecm came from o'riellys
     
  6. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    maby you have a short some where in the wiring. There are four wires total and only two go directly back to the ECM the other two go to some other engine controals. Use a wiring digram and start looking for places where there could be a short. Besides that the only other thing i can think of is that you got sold a bad ECM to start with
     
  7. jac6695

    jac6695 1/2 ton status

    Joined:
    May 2, 2002
    Posts:
    1,860
    Likes Received:
    0
    Location:
    Christiansburg, VA
    Check all of your grounds from the battery out. That is where you will most likely find the problem. IIRC, GM has 12 volts + at the injectors all of the time, and the ground is controlled through the ECM.
     
  8. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    I'm sure the test for this is like any other GM TBI...one of the steps is to see if the ECM is seeing the spark reference signal from the module.

    If it's not, the module is bad.

    These troubleshooting charts aren't that complex, kind of frustrated that of all the people that complain of this, not one has taken the time to write up/scan in the troubleshooting flowchart for crank no start. It might already be over on thirdgen.org, can't recall if I copied and pasted it to this board.

    This was covered not that long ago on this board as a matter of fact, search will probably find it.
     
  9. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Yup replace your dist module. Also could be the magnetic pick up coil but that usulaay throws a code 42.
    Bad dist module will throw no codes besides the usual 12. But because the ECM sees no spark siginal it shuts off the injectors so the engine does not flood.
     
  10. Fierospeeder

    Fierospeeder Banned

    Joined:
    Sep 17, 2001
    Posts:
    315
    Likes Received:
    0
    Location:
    Illinois
    i doubt this is ECM related. You need to get a wiring diagram for your vehicle and start tracing.
     

Share This Page