Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

my girlfriends furd is runnin like @ss...NOW ITS ALOT WORSE....

Discussion in 'The Garage' started by 01maroonz71, Feb 21, 2007.

  1. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    i know, i know, it's a ford, but owell...she means well, she really does....anyways it's an 02ranger w/ the 3.0litre and 77k miles....it ran great until 2days ago, at which point it acting like a dirty fuel filter....but slowly got worse, it would kind of "miss" under load, and somewhat at idle....well, today i replaced the filter, no fix....then looked at all the plugs, and they all looked ok too....whatever this is, it's getting worse....and not throwing a code..

    im thinking maybe an 02sensor, or cat....but wouldn't those throw codes????

    please help if you have any idea what this could be

    thanks
    ~Dave

    i've updated it to the last post...i cleaned the maf, and it did nothing...it is slowly getting worse though whatever it is.


    go to page 4, it's been updated w/ ALOT of new parts....thanks ya'll!!!
     
    Last edited: Feb 24, 2007
  2. MuddinManny

    MuddinManny Banned

    Joined:
    Oct 18, 2006
    Posts:
    1,106
    Likes Received:
    0
    Location:
    USA
    Furd just jealous of the '83 Chevy! :D

    Honestly, it should be throwing codes. Unfortunately, it could be anything from bad gas (no pun to it running like [​IMG] ) to timing. Check the tightness of the gas cap. Sometimes if the cap on the FURD's isn't tight, it does crazy things to the engine. Happened on my '06 stang GT.

    Manny
     
  3. k204dr

    k204dr 1/2 ton status

    Joined:
    Aug 27, 2004
    Posts:
    463
    Likes Received:
    0
    Location:
    TN
    does it have a mass airflow on it? those can get out of range enough to run like crap, and still not throw codes. also, make sure theres no vacuum leaks anywhere.
     
  4. 88$PIT

    88$PIT Registered Member

    Joined:
    Sep 12, 2006
    Posts:
    66
    Likes Received:
    0
    Location:
    Lincoln CA
    Fuel pressure regulator?
     
  5. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    thanks alot manny, ill check the cap tomm.
    ...definately no code at all, but...i did just find this....

    TSB #052212 -- BUCK/JERK AND MISS DURING DRIVE CYCLE ABOVE 3000 RPM - NO DTC - 3.0L 2V GAS AND FFV ENGINE. *TT (NHTSA ID #10018746, NOVEMBER 14 2005)



    but can't find any more info on it...


    K204door...it does have a MAF sensor, and i unhooked it, and it didn't do anything, i figured maybe that would help it run better...but no code with it unhooked either.....hmmmm

    88$PIT...ill have to look into it....
    thanks guys!!!!
     
  6. dhcomp

    dhcomp 3/4 ton status Premium Member

    Joined:
    Mar 17, 2001
    Posts:
    9,862
    Likes Received:
    296
    Location:
    Truckee, CA
    fuel pump? woudl that throw a code?
     
  7. bigblazer87

    bigblazer87 1/2 ton status

    Joined:
    Dec 20, 2006
    Posts:
    333
    Likes Received:
    1
    Location:
    Elk Grove, CA
    Yeah, those MAF sensors can wreak all sorts of havoc when dirty; happened to our '98 Expedition.
     
  8. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    hmmm....wouldn't it run better when its unhooked????? if not, can it be cleaned or do i need a new one???? thanks ya'll.
     
  9. bigblazer87

    bigblazer87 1/2 ton status

    Joined:
    Dec 20, 2006
    Posts:
    333
    Likes Received:
    1
    Location:
    Elk Grove, CA
    Definitely don't unhook it, but you should be able to clean it. I forgot how we got ours cleaned, it was so long ago.
     
  10. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    yeah, what im saying is...i unhooked it while hte truck was running, and then went to hit the gas and see if it would run better, and that didn't help at all...but ill try cleaning it to see what that does, couldn't hurt i recon'
    thanks man
     
  11. BKinzey

    BKinzey 1/2 ton status

    Joined:
    Jan 13, 2006
    Posts:
    3,145
    Likes Received:
    0
    Location:
    Hollywierd, CA
    Post Pics:D







    Of your Girlfriend:D:bow: Maybe somebody close can help you out by amusing your girlfriend while you swear at the furd:haha::haha::haha:
     
  12. Jason4x4

    Jason4x4 1/2 ton status

    Joined:
    Nov 5, 2006
    Posts:
    4,505
    Likes Received:
    6
    Location:
    Chandler, AZ
    clean the maf with rubbing achohol and a q-tip, but be very careful not to damage the sensors, you will need to take the 2 tamperproof torx out to remove the sensor, then clean them, and when you unhook the maf, it will usually run bad, because the computer puts in a predetermined value when it doesn't see it. also, if it has a k+n air filter, if it has too much oil on it, it will contaminate the maf.
     
  13. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    uhh is there any codes? check engine light on? haven't seen this asked yet...
     
  14. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    no codes at all....

    and also, there's no K&N, but i did find an article on how to clean a MAF online, it says to use some electric cleaner spray stuff.

    thanks ya'll.
     
  15. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    well...i cleaned the MAF sensor, and nothing at all...it's progressivly getting worse too whatever it is.... if im at idle, in gear or not, and i turn the a/c on...it shakes the truck pretty good....but everything looks ok under the hood...and still no SES lights....would the fuel pump just **** out, or would it have symptoms like this???? thanks guys!
     
  16. 76zimmer

    76zimmer Flyin Rat Premium Member GMOTM Winner

    Joined:
    Nov 14, 2005
    Posts:
    23,034
    Likes Received:
    1,349
    Location:
    Kzoo, Mi
    Scope time....maybe ignition....as in coils or plug wires?
     
  17. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    post or PM me the vin please. I can look up TSBs from any computer with internet access.
     
  18. sledheadak

    sledheadak 1/2 ton status GMOTM Winner

    Joined:
    Apr 29, 2005
    Posts:
    1,283
    Likes Received:
    1
    Location:
    anchorage,alaska
    make sure the egr valve isnt leaking.
     
  19. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    nvm, forgot I could just run the TSB number.

    Camshaft Synchronizer.

    Not an exceptionally expensive item, but you kind of need a special service tool to install it, and its not so easy to come by.

    Only diagnostic procedure requires a Ford scan tool so I can't help give you any tips.
     
  20. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    hey sled dog....how did you come up with that???? is it off the TSB number i gave earlier...that is just something that i found online earlier...but it's kind of running like $hit at all RPM's...not just over 3k...runnin worse under 3k actually....ill have to check the egr, then change plugs/wires tomm and see where im at...thanks again ya'll...
     

Share This Page