Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

my NEW engine is going to crap, whats wrong

Discussion in 'The Garage' started by TXsizeK5, Oct 5, 2002.

  1. TXsizeK5

    TXsizeK5 1/2 ton status

    Joined:
    Aug 26, 2001
    Posts:
    2,518
    Likes Received:
    0
    Location:
    College Station, TX
    Ok... well first of all.. i changed my oil yesterday 'parantly didnt put the new filter on right so when i started it oil started pouring out! so i had to go buy more oil =/ (stupid me i know)
    that just tops off my anger... anyway ive had this new engine for about 500 miles now... and it's off! the idle varies alot... like sitting at a stop light it jumps from 600-900 and back and forth... someimtes it dies and once i turned it off and it sounded like it wanted to turn back on... is that simply timing or what?! thanks
     
  2. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Have you checked for any trouble codes or put a scanner on it ? A good scanner is a must if you want to work on a computer truck.
    Have you checked to make sure that all the sensors are hooked up and working?
    Check the gasket between the manifold and TB maby it is leaking. Causing a lean mixture.
    When you set the timing did you disconnect the black and tan wire located on the drivers side firewall ? Tthe timing will be way off if it is set without disconnecting that wire(timing bypass).
    Just a few ideas.
     
  3. heavy4x4

    heavy4x4 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    3,270
    Likes Received:
    0
    Location:
    Delafield, Wisconsin
    I would look at timing before anything else.
    Also, improper cam break-in could be your problem, (but unlikely)
    Did you buy the engine and have it installed by a shop? Or build it and put it in yourself? If you bought it, before I'd even touch it, I'd take the truck to the place of purchase and have them look at it. Let them know how /forums/images/graemlins/angryfire.gif pissed you are that your new engine is a dog. Warranty?
     
  4. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    sounds like timing to me also check all vacume lines
     
  5. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    sounds like the advance weights in the distributor are loose as well as timing. Loose advance weights will cause the idle to flucuate as well as a vacuume leak will. Another posibility is the vacuume line for the distributor is connected on the wrong port.

    John
     

Share This Page