Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

my s10 wont start

Discussion in 'The Garage' started by 86chevybanshee, Feb 21, 2005.

  1. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    well i went out this morining to move my s10 and it wouldnt start. its a 92 with a 2.8 tbi, the night before it ran great. but when i went to start it this morining it wouldnt start, it would just crank. i sprayed starting fluid down there and still nothing.

    any suggestions?
     
  2. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    did you check the spark
     
  3. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    yea, its a weak spark
     
  4. 85burbanator

    85burbanator 1/2 ton status

    Joined:
    Feb 10, 2003
    Posts:
    577
    Likes Received:
    0
    Location:
    lake orion, mi
    replace the coil or check the coil wire. could gave got some moisture in there or something.
     
  5. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    ok anything else i should check
     
  6. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    check your pick up coil.
     
  7. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    i put an accel coil pack my friend gave me and it still wont start
     
  8. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    did you check your pickup coil? It is under the cap and hooks to the ignition modual which you should also check
     
  9. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    how can i tell if thats bad?
     
  10. 1979jimmy350

    1979jimmy350 1/2 ton status

    Joined:
    Mar 24, 2004
    Posts:
    3,069
    Likes Received:
    0
    Location:
    Ann Arbor Mi
    for the pick up coil use a ohm meter and check the restance of the coil it should should be between 500 and 1500. the ignition modual you can have checked at auto zone. you do not have to take the distrubitor out to test either of these. If both of these it could be your computer.
     
  11. scrappyk5

    scrappyk5 1/2 ton status

    Joined:
    Mar 17, 2002
    Posts:
    2,099
    Likes Received:
    0
    Location:
    virginia
    i would change the ignition module.

    also , are you sure its a 2.8 ?
     
  12. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    yea positive its a 2.8
     

Share This Page