Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

my th350 shifts weird.

Discussion in 'The Garage' started by the excuse, May 28, 2004.

  1. the excuse

    the excuse 1/2 ton status

    Joined:
    Dec 9, 2003
    Posts:
    209
    Likes Received:
    0
    Location:
    san diego
    i installed a trans cooler so now my 350 runs about 100 degrees when on the freeway. when ever i first start it my tranny acts like it is in neutral when i shift into reverse or first. for example ill start my car put it in drive and the engine will just rev, then it will catch like a second later and go into drive. whats the deal? in reverse it is the same. once it is started it will shift like normal.
     
  2. hatchetjack

    hatchetjack Registered Member

    Joined:
    Feb 13, 2004
    Posts:
    28
    Likes Received:
    0
    Location:
    LA (lower Alabama)
    Did you add fluid to make up for that lost in the extra space?
     
  3. the excuse

    the excuse 1/2 ton status

    Joined:
    Dec 9, 2003
    Posts:
    209
    Likes Received:
    0
    Location:
    san diego
    the fluid i inbetween the low and full marks. the tranny should be hot when checking the fluid right?
     
  4. gm guy

    gm guy 1/2 ton status

    Joined:
    May 1, 2004
    Posts:
    151
    Likes Received:
    0
    Location:
    Vancouver Island but work in Ft Mcmurray Alberta C
    Yes hot and in nuetrel (sp). Oh and block the wheels!
     
  5. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    sounds just like your low on fluid /forums/images/graemlins/yikes.gif some people don't know you have to have the motor running and in park or neutral when checking the tranny fluid
     

Share This Page