Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

My trans will not upshift

Discussion in 'The Garage' started by tough82, Nov 9, 2005.

  1. tough82

    tough82 Newbie

    Joined:
    Sep 7, 2004
    Posts:
    4
    Likes Received:
    0
    Location:
    Chicago, Illinois
    Like the title says, my trans won't upshift, stays in 1st. It's an 82 k-25 with th400. Any ideas?
     
  2. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Shouldn't prevent the trans from upshifting, mainly firmness, but is the vacuum line hooked up to the modulator and not leaking?
     
  3. trailblazr81

    trailblazr81 1/2 ton status

    Joined:
    May 27, 2005
    Posts:
    931
    Likes Received:
    0
    Location:
    Hollister, CA
    Ive had the vavuum modulater and line cause my TH350's to not want to shift. Can you manually shift it through the gears?
     
  4. 79k20350

    79k20350 3/4 ton status

    Joined:
    Nov 22, 2004
    Posts:
    7,757
    Likes Received:
    1
    Location:
    Ct
    is there enough fluid in it? :rolleyes: if theres not the tranny cant build enough pressure to shift into second & third
     
  5. BadBob

    BadBob 1/2 ton status

    Joined:
    Aug 14, 2005
    Posts:
    158
    Likes Received:
    0
    Location:
    Lyndon, KS
    governer might be stuck, they tend to do that once in a while. Yank it out and spray it down with carb cleaner.
     
  6. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,553
    Likes Received:
    939
    Location:
    Massachussetts
    Govenor ....

    It could be the modulator,but doubtful..usually it will eventually upshift when the truck gets going fast enough,or you can pull it into low manually and upshift it by hand..if thats the case,its the modulator or vacuum hose..

    I've had the nylon govenor gears strip out--or they crack where the roll pin holds them to the govenor itself..once the govenor stops turnng,it'll never come out of first..I bought my van cheap because the previous owner thought it "needed a tranny",when in fact it was just the govenor gear.. :laugh:

    Other than that I'd guess something went awry in the valve body,one of the sleeve valves might have stuck..or perhaps the detent (downshift) switch is stuck in the "passing gear" mode.. :confused: :crazy:
     
  7. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Electric downshift on the TH400 is 3-2 only, no downshift 2-1 by the switch, that'll save some diagnostic time. :)
     
  8. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,553
    Likes Received:
    939
    Location:
    Massachussetts
    Really??

    Thats a suprise,my TH400 I have in my 82 K20 diesel I ran with the modulator vacuum hose off and shifted it manually,to see if the switch controlling the modulator's vacuum was causing it to shift weird(and it was!--I found a way to bypass it)..I could floor it in 3rd gear at 25mph,and it would downshift right into first gear! :eek1: causing the injector pump govenor to kick in and kill the motor momentarily!..

    ..so if the electric detent solenoid won't downshift it into first,what did??--couldn't have been the modulator,its hose was unplugged!..maybe something internal in the valve body takes over?.(it coudn't be the govenor either,it only did this when I floored it!).
    Is it like the thing in the valve body,that makes a TH400 upshift into 2nd automatically at 5200 rpm,even if the shifter is in "low"??..

    I'm not arguing,just curious what DOES make it shift into first,if the detent or modulator doesn't?... :confused: :crazy:
     
  9. tough82

    tough82 Newbie

    Joined:
    Sep 7, 2004
    Posts:
    4
    Likes Received:
    0
    Location:
    Chicago, Illinois
    Thank you all for the info. I finally got some time today to work on my truck. Pulled out the governor and the gear is perfectly fine. The line from the modulator is connected. It finally upshifted into 2nd when I floored it. I unplugged a wire coming from the drivers side of the trans which goes inside the cab, and it shifts at normal rpm. Seems to be driving fine with it disconnected. What the heck is that wire for? :confused:
     
  10. 79k20350

    79k20350 3/4 ton status

    Joined:
    Nov 22, 2004
    Posts:
    7,757
    Likes Received:
    1
    Location:
    Ct
    that line controls downshifting. if its messed up then naybe it was telling the tranmisson to downhift when it didnt need toand that is what was keeping the tranny from upshifting
     

Share This Page