Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

My Violent Rattle

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Capman2k, Sep 17, 2001.

  1. Capman2k

    Capman2k 3/4 ton status

    Joined:
    Jun 22, 2001
    Posts:
    5,070
    Likes Received:
    0
    Location:
    dg
    I still have my violent rattle... Along with my violent shake, a squeal seems to be coming from the front passenger side as well occasionally. The rattle is when I have the gas pedal down, when I take my foot off, it's just fine, but especially when I'm accelerating it'll be really loud and just shake... I can hear things in the back moving around and the doors about to fall off and it's not very pleasant...

    Any ideas?? When I got it back from the shop they put on a new fuel line and a new pump if that means anything to anyone :D

    79 K5 Blazer Cheyenne.... That's all I have to say about that.
     
  2. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    That could be several things. Do you have a lift or anything? Your profile doesn't say.
    Ujoints, drivshaft outta balance, broke motor or tranny mount,
    wheel bearing, ball joint.
    Was it doing it before you dropped it off at the shop?


    "you know... the guy with the BAD A$$ spring perches!!![​IMG]
    <a target="_blank" href=http://www.nashvillek5.freeservers.com>www.nashvillek5.freeservers.com</a>
     
  3. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    Yeah we need more details.

    I get all the exercise I need pushing my luck! [​IMG]
     
  4. TorkDSR

    TorkDSR 1/2 ton status

    Joined:
    Sep 1, 2001
    Posts:
    1,258
    Likes Received:
    0
    Location:
    bucks co pa
    wheels balanced? drive shafts balanced? Front brakes releasing? Distributor cap balanced(just kidding)? are the body mounts good, that's what happened to me. every time i came to stop the passenger side of the cab didn't. ShaggyK5 thought he was going for a ride without the frame a few times. rattles God Awful, and squeels like hell. all fixed by a road sign and a piece of 1" box, and some stick weldin'

    isn't that right shaggy?

    Tork DSR
    I just got a winch, it takes the fun out of things.
     
  5. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    LOL!!! A road sign!![​IMG]

    "you know... the guy with the BAD A$$ spring perches!!![​IMG]
    <a target="_blank" href=http://www.nashvillek5.freeservers.com>www.nashvillek5.freeservers.com</a>
     
  6. Jonathan

    Jonathan 1/2 ton status

    Joined:
    Apr 14, 2001
    Posts:
    293
    Likes Received:
    0
    Location:
    Little Rock, Arkansas
    I have a piece of a road sign on my truck too, I don't know why it's there but it is.

    77 Blazer, 350, NP203, K&N, 31-inch Cooper Discoverers
    <a target="_blank" href=http://community.webshots.com/user/jonathandwill>http://community.webshots.com/user/jonathandwill</a>
     
  7. Capman2k

    Capman2k 3/4 ton status

    Joined:
    Jun 22, 2001
    Posts:
    5,070
    Likes Received:
    0
    Location:
    dg
    More Details:

    I'm all stock, no lift or any of that fun stuff...
    Before I dropped it off at the shop it was running fine for about 15-20 minutes, then it would stall and have to sit for a while before it would start again.. They fixed that; the fuel pump I put on was bad and the way I had the fuel line set up the fuel would boil and evaporate before reaching the carb....



    79 K5 Blazer Cheyenne.... That's all I have to say about that.
     
  8. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    If it's fulltime still my bet would be on the CV in the front drive shaft has ate it. Last trip to tellico mine fried one of the U-Joints in it so under load the ball wasn't centered and if gave me a weird Vibe. Took a few weeks (I only drive it to trail) before I got a sound out of it that I reconized as a bad u-joint. Sure enough one $12 u-joint and my Vibe and noise was gone.
    Take out the front drive shaft put it in High Loc and drive it and see if it does it.

    It's not my damn planet monkey boy!
    <a target="_blank" href=http://communities.msn.com/OffroadK5s>communities.msn.com/OffroadK5s</a>
    75 Jimmy, Dollar
    79 Chevy Blazer, Her's
    70 Chevy Burb
    Grim-Reaper
     

Share This Page