Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Nagging Electrical Gremlin

Discussion in 'The Garage' started by behemoth, Sep 2, 2002.

  1. behemoth

    behemoth 1/2 ton status

    May 16, 2000
    Likes Received:
    Northwest Florida
    I replaced my horns recently. When I bought the truck last December, it only had
    one in the first place, so I picked up two brand new ones from LMC. The original
    OE horns had only one terminal to hook the wire to. The new ones have two - so I
    assumed one was hot and the other a ground. No problem. Now, every time I try
    to actually use them, the fuse blows. This also affects the cig lighter, which I use
    to plug my phone into. Right now, I have the horns disconnected since having
    access to power for the phone is more important that using the horns. Anyone have
    any ideas as to what's causing the fuse to blow? Thanks !
  2. HispanicPanic

    HispanicPanic 1/2 ton status

    Mar 21, 2001
    Likes Received:
    El Paso, Texas
    you said the new ones have two wires so that means they are both hot when they complete a circuit they should honk, so if you have one going to a hot wire and another going to a ground it will blow your fuse when you push the horn so any way just complete the loop remember both wires are hot the screws or mounts themselves ground it out. hope i helped and not confused you even more /forums/images/icons/confused.gif

Share This Page