Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

need help on axle

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 85chevy4x4, Sep 17, 2002.

  1. 85chevy4x4

    85chevy4x4 Registered Member

    Joined:
    Apr 26, 2002
    Posts:
    63
    Likes Received:
    0
    Location:
    kansas city, kansas
    I've got an 85 chevy 3/4 4x4. It has the 10 bolt front end. I replaced my hubs last night with warn hubs. After removing the original hubs I noticed some play at the end of the axle shaft where you can see the splines. I looked at the end of the axle tube where the cv joint starts to go into the hubs and it looks like maybe there should be a seal and a bearing? Is it just supposed to be open? I figured that if there was a seal and it's destroyed then oil would be coming out the ends of the axle. I checked and had plenty of fluid. It doesn't look like it ever had a seal or bearing in there. Also how do I get the nut off that holds the lower ball joint on? I could barely get a wrench on there. /forums/images/icons/confused.gif
     
  2. Shaggy

    Shaggy 3/4 ton status

    Joined:
    Dec 15, 2000
    Posts:
    6,737
    Likes Received:
    0
    Location:
    Los Banos, CA
    <font color="green"> There isn't suposed to be a seal or bearing there, it's just open. Dana and GM corporate front axles haev inboard seals on the front axle, they are near the diff. </font color>
     
  3. 85chevy4x4

    85chevy4x4 Registered Member

    Joined:
    Apr 26, 2002
    Posts:
    63
    Likes Received:
    0
    Location:
    kansas city, kansas
    Thanks for the quick response. I guess now I can put the front end back together without fear of it leaking. I don't have to mess with taking out those balljoints either /forums/images/icons/cool.gif .
     

Share This Page