Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

need help on egr!!!

Discussion in 'The Garage' started by BiggerRigger, Dec 5, 2002.

  1. BiggerRigger

    BiggerRigger Registered Member

    Joined:
    Nov 3, 2002
    Posts:
    81
    Likes Received:
    0
    Location:
    C.D.A. Idaho
    I posted in the sencond gen. form but have not figured it out yet. The egr works fine if you push it in and hold your finger it will hold in one place till you let off. And when its warm it will work on its own like it should but that is the problem when it does its thing the whole truck starts to run real ruff and will die if you do not give it some more gas. Or if you are going along in first gear(3 speed manual) and hold the gas in one spot it will start to sound like a top fueler and go whump,whump,whump till you give it some gas and it smooths out like nothing was wrong.
    Going down the road at speed you can feel it doing the same thing kind of chugging and Im sure this is the egr system but there is my question how do I fix this little problem?
    I should add that when I took the egr off to check it both bolts were loose on the unit but I checked the gasket and it was in fine shape so I used it over I allso checked the mounting base with a strait edge to see if it were warped and it was fine but the problem continues can you shed some light?
    Aaron
     
  2. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Did you "ask" the computer (89 right) to see if it's sensors say anthything is wrong?

    I would think either the EGR is leaking/bad or a sensor is not reading something and thinking it needs to open the EGR. To be sure, disconnect the EGR and see how it runs. (For sure the Check Engine Light will come on). Now the computer should go into "limp home mode".

    Check for codes BEFORE disconnecting the EGR.
    Good luck.
     
  3. BiggerRigger

    BiggerRigger Registered Member

    Joined:
    Nov 3, 2002
    Posts:
    81
    Likes Received:
    0
    Location:
    C.D.A. Idaho
    yes I ahve checked many times and I have no codes at all that was the first thing that I tried. as for the egr should I unhook and plug the vacum or unplug the controler that the egr gets its comands from?
     
  4. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    That's weird that you didn't get any codes.

    Check for general vaccuum leaks.

    I would pull and disconnect the vacuum line.
     
  5. BiggerRigger

    BiggerRigger Registered Member

    Joined:
    Nov 3, 2002
    Posts:
    81
    Likes Received:
    0
    Location:
    C.D.A. Idaho
    and yes I have tryed the old vaccum leak test with propane and found nothing. I just got back from a test drive and it seems that when I tightened the EGR back up it made it a little worse(EGR was loose before I started to check things out)but the EGR valve is moveing "working" as it should from what I have read so far.
    Is there any other tips to help hunt this down?
     
  6. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Might have clogged intake passages. Take off the valve and run it. If it sounds normal, they are clogged. Also, check the vacuum solenoid
     
  7. '72brett

    '72brett 1/2 ton status

    Joined:
    Dec 3, 2002
    Posts:
    166
    Likes Received:
    0
    Location:
    northwest Iowa
    sounds like a vacuum problem to me...
     
  8. BiggerRigger

    BiggerRigger Registered Member

    Joined:
    Nov 3, 2002
    Posts:
    81
    Likes Received:
    0
    Location:
    C.D.A. Idaho
    if thats the case then how does one go about uncloging this?
     
  9. BiggerRigger

    BiggerRigger Registered Member

    Joined:
    Nov 3, 2002
    Posts:
    81
    Likes Received:
    0
    Location:
    C.D.A. Idaho
    also I have checked and rechecked every vac line and connector from one end to the other and have found no leaks
     
  10. yunit

    yunit 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    3,068
    Likes Received:
    0
    Location:
    Oakland, NJ
    If you bypass the EGR and the truck runs smooth, then the EGR valve is the problem, but you will need to replace the EGR valve or it will screw up the MAP sensor and cause the truck to run richer and richer to the point that the truck will not even start anymore; ask me how I know. /forums/images/graemlins/grin.gif
     
  11. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    You'd have to take the intake off and clean it out with a wire brush and lots of carb cleaner
     

Share This Page