Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Need help quick.. TBI is not working

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by chevyracing, Mar 9, 2003.

  1. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    1988 Chevy 1/2 ton
    350 TBI


    Ok, we just changed the fuel filter, it was bad. We still are not getting any fuel to the TBI. I checked all of the connections and they appear good. There is not any noise comming from the TBI. (no Clicking) If I pour fuel inside of it the truck runs for a second so we have ignition. I pulled the input line off the back of the TBI and fuel is pumping to it well. We also checked the fuse, it is okay.

    Is this the ECM? If it is how much are they?

    Thanks,
    John
     
  2. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    go get a noid light and see if the injectors are gettin a signal to fire, u unplug the wirelooms off the top of the injector and plug in this light. it should light up that light good. If its getting a weak signal to em, you might check the temp sensor, mine was stuck on 210 degrees and when it was 30 it wouldnt spray. If it doesnt light.......im not sure......computer maybe, when i was lookin at mine pepboys wanted i think 175 for a rebuilt one.
     
  3. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    Should we be hearing a clicking noise before the engine starts?

    John
     
  4. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    mine did that when the injectors werent spurting fuel, its them opening and shutting is how a firned explained it to me, so yes you should hear it, but now that they spit fuel on mine i dont notice the clicking.
     
  5. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    do you have access to a scan tool?
     
  6. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    No I don't have access to one. (scan tool). We just checked the power to the injectors with a multi meter and there is power to the injectors. The fuel is intermittingly going through the return line and we do have a steady supply from the pump. We took the return line off of the TBI and like I said, one time when we turn on the key the fuel comes out and the next time it may not. What now.

    John
     
  7. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    are the actual injectors spitting fuel? if not then i stick by what was wrong w/ mine a bad temp sensor telling it the truck is hot, so it doesnt need fuel. it was like 19.80or so at pepboys, it fixed mine...
     
  8. RockyRider13

    RockyRider13 1/2 ton status

    Joined:
    Jul 11, 2001
    Posts:
    102
    Likes Received:
    0
    Location:
    Kansas
    A guy, just the other day, had a problem like yours. The fuel filter was really clogged, burnt up the fuel pump. Do you hear the pump pressurize when the key is turned to run (not start)?
     
  9. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    Took the TBI off and messed with it, put it back on and ran a paper clip across the diagnostic plug and it fired right up...... Let's see if it stays running. I think the temp sensor is an issue too, it does not show hot, but when he cranks the truck it pegs out, then goes back down...........

    John
     

Share This Page