Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Need help with my sisters Jeep

Discussion in 'Other Rides' started by chvyhs, Mar 5, 2002.

  1. chvyhs

    chvyhs 1/2 ton status

    Joined:
    Feb 12, 2001
    Posts:
    1,469
    Likes Received:
    0
    Location:
    Murrieta, California
    It's a 90 something Grand Cheroke. She said it just stopped running. When I went to go look at it today it wouldn't start at all, so my brother in law and I went and got another battery. It started and ran for a few minutes then died. I tried jump starting and it did the same thing. After that it wouldn't start at all. I was thinking it was a coil or fuel pump problem. Thanks for any help.
     
  2. Den

    Den 1/2 ton status

    Joined:
    Jan 12, 2002
    Posts:
    142
    Likes Received:
    0
    Location:
    Arkansas
    Man.... same thing is happening with my wifes G/C... . I have NO idea on this... thinking about the fuel pump... but it is $175 so I dont want to change it if it isnt needed....
     
  3. lifted95z71

    lifted95z71 1/2 ton status

    Joined:
    Nov 19, 2001
    Posts:
    248
    Likes Received:
    0
    Location:
    birmingham alabama
    there is a flywheel position sensor that tends to go bad eventually. its one of those "why did they put that there parts". anyway that sounds to me like what it is. not that expensive from what ive heard but ive never had to put one in. you did try checking the fuel filter right?
     
  4. Den

    Den 1/2 ton status

    Joined:
    Jan 12, 2002
    Posts:
    142
    Likes Received:
    0
    Location:
    Arkansas
    Hey Im trying something today.. ICM Idle control module...ill let ya know... pray for me.... wifey HATES my Blazer....
     
  5. gokartergo

    gokartergo 3/4 ton status Staff Member Moderator

    Joined:
    Dec 2, 2000
    Posts:
    5,855
    Likes Received:
    0
    Location:
    Hollister, CA
    It is a crank case sensor... They were known to go bad. And work on and off.. My buddy had the same problem..He replaced the fuel pump, computer and a ton of other parts.. Then he took it to the dealer and there was a recall on it...Dan
     
  6. Den

    Den 1/2 ton status

    Joined:
    Jan 12, 2002
    Posts:
    142
    Likes Received:
    0
    Location:
    Arkansas
    Well... I THINK the ICM fixed it... Im prolly jinxing it buy putting this post here...LOL... I hope not.. has been about a week w/o a no start... so..... Wifey is all /forums/images/icons/smile.gif
     
  7. chvyhs

    chvyhs 1/2 ton status

    Joined:
    Feb 12, 2001
    Posts:
    1,469
    Likes Received:
    0
    Location:
    Murrieta, California
    Finally got her Jeep fixed. It was the fuel pump. Now I can't figure out why the little computer display wont stop blinking. I think she just needs to get rid of it.
     

Share This Page