Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Need help with transmission...

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by no3rdseat, Jun 2, 2003.

  1. no3rdseat

    no3rdseat Newbie

    Joined:
    May 17, 2002
    Posts:
    4
    Likes Received:
    0
    I've got an '89 Jimmy with 350 and auto. I was on a 400 mile trip last weekend and on the way back my transmission started acting up. At highway speed, if I went to accelerate, it would clunk out of overdrive, and then finally clunk and knock back into overdrive. Yesterday I took it to the store and the problem was much more severe. It would hang onto every gear and wind way out before shifting up to the next gear (coming back down is not a problem). Then at highway speeds it likes to clunk between 3rd and OD. I put it into 3rd manually but it still tried to clunk around. All driveshaft joints are tight and new. Any ideas on what it might be and how much it's gonna cost me? Thanks.

    Rick Stewart
     
  2. KRAZIE87K5

    KRAZIE87K5 1/2 ton status

    Joined:
    Feb 23, 2001
    Posts:
    3,369
    Likes Received:
    0
    Location:
    Chicago, IL
    Have you pulled the pan and checked the fluid for debris yet? If there is a sliver tint to the fluid, you've got issues that only a real tranny shop can repair. OR you go to the local junk yard, and get another 4WD TH350 for $100-150 and slap that in with a aux. cooler, and call it a day! /forums/images/graemlins/thumb.gif

    -Dan
     
  3. fredekr

    fredekr Registered Member

    Joined:
    Jul 12, 2002
    Posts:
    92
    Likes Received:
    0
    Location:
    Colorado Springs, CO
    My TH350 has this kind of shifting behavior when it get low on fluid, which happen frequently right now beacuse the seal in the adapter between my TH350 and NP205 is leaking. /forums/images/graemlins/angryfire.gif Have you checked the ATF level and/or what kind of oil is in the tcase? I pulled the *fill* plug on my tcase and got 1/2 gallon of reddish ATF/gear oil mix pouring out. /forums/images/graemlins/eek.gif

    cheers,
    Kevin
     
  4. Ryan B.

    Ryan B. 3/4 ton status GMOTM Winner

    Joined:
    Jul 18, 2001
    Posts:
    5,693
    Likes Received:
    0
    Location:
    CA
    So this is a 700r4 tranny since your saying its going back and forth between 3rd and overdrive?
    What gear ratio/tire size are you running?
    I'd agree, check the fluid level with the engine running, tranny in park. Low fluid level will be the first thing to cause problems.
     
  5. no3rdseat

    no3rdseat Newbie

    Joined:
    May 17, 2002
    Posts:
    4
    Likes Received:
    0
    Thanks for the replies, guys. The fluid level is full and clean. Everything on the truck is stock size, original equipment. The kickdown cable is not loose or binding. I took it to the local tranny guru and he thinks the nylon gear on the end of the governor is probably torn up and the torque converter is about ready to give up the ghost. If that's all it is I'll be releived. He's going to take it apart in the morning so I'll find out for sure tomorrow. I'll post it to the list if anyone's interested. Thanks again.

    -Rick Stewart
    /forums/images/graemlins/k5.gif
     
  6. gumneck

    gumneck Registered Member

    Joined:
    Feb 6, 2003
    Posts:
    89
    Likes Received:
    0
    Location:
    VA
    I'll chime in here, my 91 blzr would shift hard after changing the trans fluid/filter and then wouldn't shift out of first. It would wind up the motor prior to shifting if it did at all. Father inlaw told me to replace the governor. Its a small $5.00 part from a trans shop you can replace in less than 5 minutes. Just pop the dust cover off on rear drivers side of trans pull that nylon gear out put new one in dust cover tapped with rubber hammer back on and done. My culprit was most likely the changing of fluid caused trash to get stuck in a valve. Trans shop man gave me free advice if gov didn't work. From stand still, pop the accelerator with it in drive. It should force the trash out. Don't wind the motor up, just poppin it.
    Good luck. /forums/images/graemlins/thumb.gif
     
  7. Calclips

    Calclips 1/2 ton status

    Joined:
    Apr 4, 2001
    Posts:
    1,005
    Likes Received:
    0
    Location:
    Swartz Creek, Michigan/Flint while in school
    My 700 that I had in a 90 Z71 started holding all shifts until about 4k and would then instantly upshift very hard... I replaced the governor and it did nothing... the whole thing was toasted. Hopefully yours isn't, when mine went it costed me right around $950 for full R&R and a 1 year warranty.
     
  8. Nrose07

    Nrose07 1/2 ton status

    Joined:
    Mar 29, 2000
    Posts:
    267
    Likes Received:
    0
    Location:
    Salem ,Or
    Go get a TransGo Junior "upgrade/fix" kit. Part# SK 700-Jr "No Stick TV, Pressure and Shift Correction". It fix the factory issues, like "TV won't adujst-Late or no 4th. Soft, bang, or slide bump 1-2. 2-3 Cutloose - Falls out of 4th." And lots of other things, not a shift kit, just fixes factory issues. You can do it installed in the vehicle, take your time, comes with great directions, about $30. Get the valve body gaskets, filter, and fluid about $60.00.
     

Share This Page