Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

need help

Discussion in 'The Garage' started by cjb88jimmy, Dec 10, 2003.

  1. cjb88jimmy

    cjb88jimmy Newbie

    Joined:
    Dec 10, 2003
    Posts:
    2
    Likes Received:
    0
    Location:
    plattsburgh ny 20miles from canada
    hi folks newbie here.. i have a 88 jimmy stock everything.last week had ignition module go bad replaced it then it developed for poor performance. rough idle rich exhaust not showing engine light. please help any info would be great.... thanks
     
  2. Okiemuddog

    Okiemuddog 1/2 ton status

    Joined:
    Mar 3, 2003
    Posts:
    1,260
    Likes Received:
    0
    Location:
    Guthrie, Oklahoma
    well if the module was going south then it might have fouled the plugs, check them and you firing order. If that all looks good then doule check all you plugs around the distributor and make sure something is not loose or unplugged. /forums/images/graemlins/thumb.gif

    Oh and welcome to the board
     
  3. 99firehawk

    99firehawk 1/2 ton status

    Joined:
    Dec 15, 2002
    Posts:
    491
    Likes Received:
    0
    everything he said, also make sure you didnt change your timing (yes I know you have no need to even loosen the dizzy to change the module but I have seen people do lots of stupided things)
     
  4. cjb88jimmy

    cjb88jimmy Newbie

    Joined:
    Dec 10, 2003
    Posts:
    2
    Likes Received:
    0
    Location:
    plattsburgh ny 20miles from canada
    thnks guys will check this mornig
     

Share This Page