Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Need ignition help fast

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Predator, Aug 11, 2001.

  1. Predator

    Predator 1/2 ton status

    Joined:
    Jun 19, 2001
    Posts:
    130
    Likes Received:
    0
    Location:
    OKC,OK
    Need some help, my K5 is broke down at Wal-mart. Here's what happened. I was just driving through the parking lot and it died like someone turned the key off. I checked for ignition power at the distr. cap and it was good. It will turn over but doesn't fire. Everything is new. Any thoughts???
     
  2. Prembird

    Prembird 1/2 ton status

    Joined:
    May 15, 2001
    Posts:
    811
    Likes Received:
    0
    Location:
    kc, mo.
    well it take 3 things for a motor to run.. fuel,fire, and air.... well... you say there is power there (fire), so i would check the fuel next... Take some starting fluid and put a little in it and see if it kicks over.. if it does then you know where to look next..

    Prembird
    [​IMG] <font color=blue> If it aint</font color=blue><font color=red> LOUD </font color=red><font color=blue> Then turn it </font color=blue><font color=red> UP</font color=red> [​IMG]
     
  3. '73 K5

    '73 K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,763
    Likes Received:
    0
    Location:
    Kansas
    Are you sure the power is actually making it to the spark plugs? Try the starting fluid idea like Prembird said and if that doesn't work then the first ignition part I would replace would be the ignition module. They usually are all or nothing and fail without warning. Maybe you got a bad one. Good luck.

    '73 K5
    Chevy good...Ford bad
     
  4. Predator

    Predator 1/2 ton status

    Joined:
    Jun 19, 2001
    Posts:
    130
    Likes Received:
    0
    Location:
    OKC,OK
    It just doesn't sound like the spark plugs are firing. I'm pretty sure it's getting gas cuz I could smell it after I cranked on it a little. Could it be in the distr. somewhere?
     
  5. Predator

    Predator 1/2 ton status

    Joined:
    Jun 19, 2001
    Posts:
    130
    Likes Received:
    0
    Location:
    OKC,OK
    Sounds like it could be that.
     
  6. Prembird

    Prembird 1/2 ton status

    Joined:
    May 15, 2001
    Posts:
    811
    Likes Received:
    0
    Location:
    kc, mo.
    yea it could be the distributer doin it also.. pull the cap and look at it... Also is there a way you might have gotten water up there... i had an old mustang that when it rained or i went threw a big puddle it would just die on my... but would run for a couple of minutes after i went threw it.. i found out that water was getting into the distributer cap... couldnt figure out where but it was... look at you distributer and rotor... take a peice of sand paper and clean up the connections on it... unless you think they look bad.. then its time to replace... Also if you have an extra spark plug laying around you could take off a wire and use the spark plug to see if you are getting power.. then go to the next plug wire, etc.. till you check all of them... Just dont be holding onto the plug when someone cranks on the ignition....You'll get the shock of your life.. heheheh... know if you get fire, and you are getting fuel..... well make sure it can breath.. check the butterfly on the carb to make sure it is open... choke could be stuck on it and locked down.. Now if you dont have fire there... then you need to look into the coil... those will go out without any notice at all... there are ways to check all of this but that should give you a really good place to start..


    Prembird
    [​IMG] <font color=blue> If it aint</font color=blue><font color=red> LOUD </font color=red><font color=blue> Then turn it </font color=blue><font color=red> UP</font color=red> [​IMG]
     
  7. RESTORE89

    RESTORE89 1/2 ton status

    Joined:
    Jan 31, 2001
    Posts:
    548
    Likes Received:
    0
    Location:
    CHAS SC
    great ideas, but before you check all the plug wires and etc, use the old spark plug and attatch to the coil wire where it connects to the distributor and see if you have power from the coil. if you do not have an old plu, you can use a screwdriver and just hold about 1/8" from a grounded bolt and have somebody else turn over and look for spark, just be careful as to what you touch durring the firring, it kinda smarts (stupid's would be more appropriate) when you get hit with 50,000 volts, but it is not dangerous, just makes your muscles sore

    last saturday my next door neighbor who is 79 had his dodge car do the same thing, and checked a plug wire no juice. checked the coil wire and had juice, took off cap and rotor and the thing was cruddy, so i cleaned with a file, and re assembled. still no juice. went to parts house and got a new cap and rotor ($9) total and re installed and the thing ran fine
    good luck and let us know what the outcome is. it lets us all know for future repairs


    It needs a bigger motor.
    what's in it now?
    doen't matter it NEEDS A BIGGER MOTOR
    89 350tbi/700r4h/np208/4.11's
     
  8. Predator

    Predator 1/2 ton status

    Joined:
    Jun 19, 2001
    Posts:
    130
    Likes Received:
    0
    Location:
    OKC,OK
    ok. I went back out there and checked for gas (ok), rotor is turning and changed the whole cap and coil. Checked the ignition wire, still getting power at start and run. It's the only wire going to the motor except for the engine ground, alt. wires, starter wires and choke wire. not wet, not dirty. GGGRRRRRRRR. haven't tried sticking an extra plug in yet. guess I'll try that next, but I don't think there is fire coming out of the cap. Anything else????
     
  9. RESTORE89

    RESTORE89 1/2 ton status

    Joined:
    Jan 31, 2001
    Posts:
    548
    Likes Received:
    0
    Location:
    CHAS SC
    did you change rotor??
    you need to check for juice going into cap before checking juice coming out
    could be ignition module



    It needs a bigger motor.
    what's in it now?
    doen't matter it NEEDS A BIGGER MOTOR
    89 350tbi/700r4h/np208/4.11's
     
  10. Mr.Chevy4x4

    Mr.Chevy4x4 1/2 ton status

    Joined:
    Jun 16, 2000
    Posts:
    1,932
    Likes Received:
    0
    Location:
    Sims, NC
    Sounds to me like the ignition module in the distributor. If there is power to the dist. and the coil is good, and the cap and rotor is new but there is no spark coming out of the dist., then it sounds to me like the module is fried. Good luck! Let us know what it was.

    '85 K5 : Run it til it breaks, then fix it and go again!
     
  11. Predator

    Predator 1/2 ton status

    Joined:
    Jun 19, 2001
    Posts:
    130
    Likes Received:
    0
    Location:
    OKC,OK
    yeah, I guess I'm gonna have drag it home and change distributors out. [​IMG] I think it's the ignition module (Its in the base of the distributor with 3 wires coming out, right) The distributor body is the only thing that I used from my old motor and that's prob it.
     
  12. newyorkin

    newyorkin 1 ton status

    Joined:
    May 8, 2001
    Posts:
    16,555
    Likes Received:
    157
    Location:
    Los Estados Unitos
    You don't need to take out the dist to change the module. Just take off the cap, and you should be able to unscrew the module pretty easy. Make sure you use the heat conductor that comes with the new one, or it'll fry pretty quick...

    Ratch
    <a target="_blank" href=http://k5.8m.com>k5.8m.com</a>
    **Ever stop to think... Then forget to start again?**
     
  13. RESTORE89

    RESTORE89 1/2 ton status

    Joined:
    Jan 31, 2001
    Posts:
    548
    Likes Received:
    0
    Location:
    CHAS SC
    i agree no need to drag it home, just pull of the distributor cap and you can access the module i think it has only 2 small phillips head screws, 1 at eack end, and it is about 1/4" thick and kinda curved, maybe somebody can get a picture, but it is real easy to swap


    It needs a bigger motor.
    what's in it now?
    doen't matter it NEEDS A BIGGER MOTOR
    89 350tbi/700r4h/np208/4.11's
     
  14. Predator

    Predator 1/2 ton status

    Joined:
    Jun 19, 2001
    Posts:
    130
    Likes Received:
    0
    Location:
    OKC,OK
    [​IMG]WOOOOHOOOOOO!!!!!!!!!!!!!!!!! You guys are great!!!!!! Changed out the ignition module and it fired right up. The new one didn't come with a heat conductor, though, just some electric grease. I just plugged into the two harnesses and screwed it down. What part is the heat conductor?
     
  15. Jason73K5

    Jason73K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    592
    Likes Received:
    0
    Location:
    Fresno, Ca
    thats the dielectric grease that you used, it just improves heat conductivity.

    73K-5: TBI350/TH-400/NP-203/14FF/D44
    Topless, doorless and no tailgate!
    Fresno, CA
     

Share This Page