Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

need new engine help...

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by StageZ, Jan 29, 2002.

  1. StageZ

    StageZ Registered Member

    Joined:
    Jul 2, 2001
    Posts:
    92
    Likes Received:
    0
    Location:
    Los angeles CA
    I just built a 383 stroker from scratch... every part on her is new, torqed to spec and all the clearances platigated 3 times... Unfortunately, because of the 400 crank, I cant use a timing gun... I set the timing by checking vacuum and setting it at its highest reading... I am having two problems... one, the temp seems to warm up quick and run right next to hot... and second, she is REAL choppy when at low RPM... I have to rev her if she drops below 1300. if I don't, she will stall... Is this normal for a new engine? I am running a MSD 6a and the spark seems clean and my old edelbrock 600 from my old 350... I opened the choke using a tie-strap so I wouldn't run too rich on break-in... would that cause a choppy idle?I am not using a radical cam and she seems to run fine at 1500 + RPMs... If you guys could give me any suggestions it would be much appreciated... thanks in advance...
     
  2. kilroy

    kilroy Registered Member

    Joined:
    Nov 25, 2001
    Posts:
    85
    Likes Received:
    0
    Location:
    Alaska, Anchorage area
    May be to advanced, is it also hard starting? try retarding it 5 Deg or so and see if it improves.
     

Share This Page