Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Need some quick help on this one!!!!

Discussion in 'The Garage' started by hunterguy86, Mar 14, 2005.

  1. hunterguy86

    hunterguy86 1/2 ton status

    Joined:
    Jan 10, 2005
    Posts:
    2,477
    Likes Received:
    0
    Location:
    San Marcos, Texas
    I have an 86 k5. I need to get her inspected so i can get her goin before i have to go back to college on saturday. The problem is the horn wont work. When I press it all I get is a clickin sound from under the dash. I checkked all the fuses and everything is good. So, where do I start?

    Thanks as always for the help yall.

    Dustin
     
  2. wraenking

    wraenking 1/2 ton status

    Joined:
    Apr 30, 2003
    Posts:
    1,493
    Likes Received:
    0
    Location:
    Toms River, NJ
    follow the wirimg amd look for a short. if all else fails, run a new wire.
     
  3. Mantruck-k5

    Mantruck-k5 Registered Member

    Joined:
    Feb 16, 2005
    Posts:
    18
    Likes Received:
    0
    Location:
    Fairfield CA
  4. hunterguy86

    hunterguy86 1/2 ton status

    Joined:
    Jan 10, 2005
    Posts:
    2,477
    Likes Received:
    0
    Location:
    San Marcos, Texas
    Thanks for the help yall. i found the problem. A wire inside the horn relay came unsoldered. I dropped some solder on it, put the relay back in and now it works good as new.
     

Share This Page