Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

new intake,carb,air cleaner..know it hesitates?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by wheelin247, Mar 1, 2001.

  1. wheelin247

    wheelin247 1/2 ton status

    Joined:
    Aug 29, 2000
    Posts:
    178
    Likes Received:
    0
    Location:
    hayward,ca
    i have a mild cam in my truck and i just put in the new performer intake and 600 cfm perfomer carb and a k@n air cleaner and when i punch the gas it hesitates like it sucks air or somthing what could it be some poeple said i have to change me air fuel mixture but i dunno .....help?
     
  2. DMK

    DMK 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    757
    Likes Received:
    0
    Location:
    CINCINNATI, OH
    Check for vaccum leaks at intake or around carb base.
     
  3. Nrose07

    Nrose07 1/2 ton status

    Joined:
    Mar 29, 2000
    Posts:
    267
    Likes Received:
    0
    Location:
    Salem ,Or
    First, what carb do you have exactly. A Edelbrock 600cfm? OK, a Carter style or a Roch. Q-Jet style. Most likely you need to up the accelertator pump to a larger cc displacement or in the case of the Q-jet lower the secondary spring pressure.

    Displacement, cubes, and did you say you drive a riceburner???
     
  4. wheelin247

    wheelin247 1/2 ton status

    Joined:
    Aug 29, 2000
    Posts:
    178
    Likes Received:
    0
    Location:
    hayward,ca
    i have a edelbrock performer 600 cfm
     
  5. DMK

    DMK 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    757
    Likes Received:
    0
    Location:
    CINCINNATI, OH
    Carb should run ok out of the box. accelerator pump should be fine on a new carb. Did you set mixture screws and idle speed. I would say vaccum leak. Did you torque bolts on intake in proper sequence? Bolts on carb tight? Maybe timing but will usally mis a idle. check your plugs for lean condition (white). If one or a couple are white probuly intake leak. How does truck idle?
     
  6. wheelin247

    wheelin247 1/2 ton status

    Joined:
    Aug 29, 2000
    Posts:
    178
    Likes Received:
    0
    Location:
    hayward,ca
    truck idles fine and runs good ,besides the hesitation the truck runs fine .
     
  7. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Make sure your vacuum hoses are hooked up correctly. It doesnt have to leak to not run well. I had mine hooked up all backwards and it ran like SH!T. Its a simple over sight. I had full vacuum where it wasnt supposed to be and vice versa. Once I got it switched it ran great!

    creepin' and crawlin'

    Jim
     

Share This Page