Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

New Lift...help!!!

Discussion in 'The Garage' started by SUB-ZERO, Mar 17, 2005.

  1. SUB-ZERO

    SUB-ZERO 1/2 ton status

    Joined:
    Oct 8, 2002
    Posts:
    219
    Likes Received:
    0
    Location:
    Virginia Beach,Va.
    I have a 87 Jimmy. Just finished installing a new 4" Rough Country lift.I did not use the sway bar drop brackets 'cause it bolted to the frame without them.I also eliminated the dual shock setup and just went with one(on the rear of the front).I did use the raised steering arm and longer brake lines.Did not shim the axles or drop the transfer case.Heres my problem...on the way to the tire shop to get new 35" tires it started to wobble violently.I suppose this is what is described as the "DEATH WOBBLE"? I did a search and read all the posts associated with this but none address getting this right after a new lift and before larger tires.It did not do this before.Any thoughts?
     
  2. JIMs70K25

    JIMs70K25 1/2 ton status

    Joined:
    Dec 31, 2001
    Posts:
    524
    Likes Received:
    0
    Location:
    Chesapeake, VA
    where you at in VA? death wooble is more for the dana60. Did you check your ball joints? Is your drag link tight?
     
  3. doggystyle

    doggystyle Registered Member

    Joined:
    Jan 31, 2005
    Posts:
    8
    Likes Received:
    0
    Location:
    washington
    are you sure your ubolts are tight? i have had and seen alot of dana 44s with some pretty violent wobble.
     
  4. SkulzNBonz

    SkulzNBonz 1/2 ton status

    Joined:
    Feb 20, 2002
    Posts:
    4,522
    Likes Received:
    0
    Location:
    OKC, Oklahoma
    I experienced something similar. It turned out one of the drag link ends (the one attached to the steering arm) was loose.

    John
     
  5. SUB-ZERO

    SUB-ZERO 1/2 ton status

    Joined:
    Oct 8, 2002
    Posts:
    219
    Likes Received:
    0
    Location:
    Virginia Beach,Va.
    I am in the Lynnhaven area where are you at.I torqued the u-bolts to 90psi.Is that adequate?It might be the drag link 'cause it looks pretty tattered.Its tight though 'cause I had to remove it to install the raised steering bracket and again to adjust the steering wheel.I will check it again though.
     
  6. divorced

    divorced 3/4 ton status

    Joined:
    Jul 20, 2004
    Posts:
    5,115
    Likes Received:
    0
    Location:
    .
    You need 130 foot pounds of torque.
     
  7. JIMs70K25

    JIMs70K25 1/2 ton status

    Joined:
    Dec 31, 2001
    Posts:
    524
    Likes Received:
    0
    Location:
    Chesapeake, VA
    Deep Creek
     
  8. ZooMad75

    ZooMad75 1/2 ton status Premium Member GMOTM Winner

    Joined:
    Apr 5, 2003
    Posts:
    1,007
    Likes Received:
    609
    Location:
    Pueblo, CO
    I just went throught the same lift this last weekend. Did not use any drop brackets for the sway bar since the rough country kit did not come with any. I did use the raised steering arm. NO Wobbles with the front end torqued together. Something must be loose or do you have a steering stabilizer?
     
  9. SUB-ZERO

    SUB-ZERO 1/2 ton status

    Joined:
    Oct 8, 2002
    Posts:
    219
    Likes Received:
    0
    Location:
    Virginia Beach,Va.
    You ain't that far..about 30 min.We should get together sometime.The Jimmy is my buddies.I have a 85 K5.I just got mine back from having the whole truck Line-x'd inside and out in Viper Red!!!You should see it!It looks bad a$$!Gonna start building some bumpers this weekend.
     
  10. 85scottsdale

    85scottsdale 1/2 ton status

    Joined:
    Dec 22, 2003
    Posts:
    283
    Likes Received:
    0
    Location:
    Lewisville, NC
    I had a all spring 4" Rough COuntry kit on my truck and had no issues, make sure everything is tight and your ball joints aren't worn out like already stated.
     
  11. SUB-ZERO

    SUB-ZERO 1/2 ton status

    Joined:
    Oct 8, 2002
    Posts:
    219
    Likes Received:
    0
    Location:
    Virginia Beach,Va.
    Just an update...put a replacement stock stabilizer in last nite and seems to have fixed the problem.On the old cylinder the rod practically fell out!!I'd say it was toast!
     
  12. AkMudr

    AkMudr 1/2 ton status

    Joined:
    Dec 30, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    Alaska
    Hampton/Newport News area here.
     
  13. SUB-ZERO

    SUB-ZERO 1/2 ton status

    Joined:
    Oct 8, 2002
    Posts:
    219
    Likes Received:
    0
    Location:
    Virginia Beach,Va.
    And I thought I was the only one with a REAL truck around here! What kind of truck you got?
     
  14. AkMudr

    AkMudr 1/2 ton status

    Joined:
    Dec 30, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    Alaska
    Just my lil red wagon :D 85 3/4 ton, 4" on 35's 350/350/205 Xover Hysteer 14bff locked.
     
  15. SUB-ZERO

    SUB-ZERO 1/2 ton status

    Joined:
    Oct 8, 2002
    Posts:
    219
    Likes Received:
    0
    Location:
    Virginia Beach,Va.

Share This Page