Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

New motor problems.

Discussion in 'The Garage' started by dirtwarrior17, Jan 16, 2005.

  1. dirtwarrior17

    dirtwarrior17 Banned

    Joined:
    May 14, 2004
    Posts:
    1,820
    Likes Received:
    0
    Location:
    Redding, CA
    Don't know if its the timing or what but it runs really good but when i barley move timing its sluggish and won't start. had to stop because my neighbors are pissed.:blush: :D so i don't know if timing was the problem... can't work on it anymore tonight. I ran it for 2 weeks with straight headers. no muffler or cat. It has a muffler on it now tho.still loud.

    Motor is modified and throttle body injected around 350-375 hp. 400 with a higher psi regulator(maybe). Has about 12 degrees of advance on the balancer. where is ballpark good timing on a hp 355? has 10:1 comp, 272 dur. 447 lift cam,holley pro-jection manifold, 670 cfm tbi, camel hump heads, flowtech headers and y-pipe, k&n , 3" exhaust, and 45 psi fuel pump with a 22 psi fuel pressure regulator. Holley makes a replacement 35-60 psi for $50.

    I don't think the stock fuel map would affect the idle but it will need a custom chip when it's on the road.

    Only thing not hooked up is the knock sensor... still waitin for a welder.
     
  2. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    Its probly the computer that is messing it up. Try getting a custom burned chip. Jet can make them for you.
     

Share This Page