Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

new problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by NoSmog73, Mar 18, 2002.

  1. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Ok I was moving the k5 out of the garage and happen to walk in front of it and noticed that the front spring the one I think it was the 2nd from the bottom the one that crurves up halfway around the front shackle on the passenger side has a gap about 1/2" or more and then the drivers side has no gap.
    I thought that a spring might be broken but I can't see any..
    Could that cause the shakes and vibe in the frontend that I have been having...
     
  2. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
  3. What kind of springs are they? and how much lift? Correct me if I'm wrong but that might be causing the vibes because the spring is'nt doing it's whole job because it's not contacting the rest of the springs. Also one thing you really should check is your centering pin. I broke the centering pin in one of my rear spring packs and my truck started "crabbing" and acting a little funny. So I would definitily check that out before anything else. Later
     
  4. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    thanks I was thinking about the center pin too,They are 4"ers and I think that the leaf that curls up (is) called a millitary wrap ???????????true or not...mike
     

Share This Page